Bug 63006 - reset set interrupt to Delete in root console login
Summary: reset set interrupt to Delete in root console login
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: ncurses (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-09 05:40 UTC by Bill Crawford
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-03 22:45:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Crawford 2002-04-09 05:40:31 UTC
Description of Problem:
After a fresh (workstation) install of Skipjack-beta2, graphical login failed
(we didn't have a mouse configured :o) and left us at console login.  After
trying to rerun X configuration from the setup menu, this crashed (will Bugzilla
this when I have more info) leaving console in non-echo mode.  Typed "reset" to
restore sane terminal handling, only to find it reported interrupt as set to
Delete.  Was expecting this to be ^C, as happens under normal circumstances on
my desktop system and has been the default for I don't know how long.

Comment 1 Bernhard Rosenkraenzer 2002-04-10 20:40:01 UTC
Can't reproduce this, reset certainly does the right thing here. 
Did you change anything in your {termcap,terminfo,inputrc}? 
Can you reproduce this on any other machine?

Comment 2 Bill Crawford 2002-04-10 23:03:12 UTC
Yes, I can reproduce.

Normally it works fine.  However if I run "setup" and try to configure X via
setup -> "X Configuration" (which fails due to the absence of a mouse) and then
quit, I'm left with the non-echoing console, and if I run "reset" at that point
it sets interrupt to delete.  In fact it says:

Erase is delete.
Kill is control-U (^U).
Interrupt set to delete.

At this point I should have told the person at the console to try "stty sane"
(sorry).

So this may just point back to a problem with "setup" and/or Xconfigurator.

I do think "setup" should try harder to leave the console in a sane state.  If a
new user is trying to get a system configured and they get stuck at a console
that's not echoing, and I tell them "type reset and hit return" I'm sort of
expecting them to get a working console back ...



Note You need to log in before you can comment on or make changes to this bug.