Bug 63009 - crc value for register_chrdev is different in i686 kernel
Summary: crc value for register_chrdev is different in i686 kernel
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-09 07:41 UTC by Mark Scott
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 20:15:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Scott 2002-04-09 07:41:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
Looking at /proc/ksyms shows that register_chrdev has a different CRC value in 
the i686 build of the 2.4.9-31 kernel from the i386 and i586 builds. Why is 
this ?
Is there a way round this so I don't have to do a seperate i686 build for my 
customer device drivers ?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compare /proc/ksyms entry for register_chrdev between kernel-2.4.9-31 i386 
and i686. Notice that the CRC values are different
2.
3.
	

Additional info:

Comment 1 Arjan van de Ven 2002-04-09 07:50:15 UTC
The i386, i586 but particularly the i686 kernel are very different internally on
a binary level. Structures are different sizes, several functions have different
sized arguments (due to highmem in i686) etc etc etc. There's no way to do 1
binary for all kernels.

The simplest thing to do is to ship the source to the customers with a simple
makefile (I can provide a good example if you're interested) and build on
demand.

Comment 2 Alan Cox 2002-04-13 17:49:47 UTC
Also Doug Ledford has a nice little kit for building the set of drivers needed
and generating driver disks. Ping dledford@redhat.com


Note You need to log in before you can comment on or make changes to this bug.