Bug 63010 - Kernel hangs during boot
Kernel hangs during boot
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-09 04:46 EDT by Need Real Name
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 04:51:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-09 04:46:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-0.16bigmem i686)

Description of problem:
Kernel hangs during boot on BP6 MoBo at 

Partition check:
hda: <hangs, here, does not print [PTBL], IDE LED instantly lights.

All variants of kernel (see below) behave just the sam way

kernel-BOOT-2.4.18-0.16
kernel-2.4.18-0.16
kernel-bigmem-2.4.18-0.16 (i686)
kernel-smp-2.4.18-0.16 (i686)

IDE configuration: Both channels of primary IDE controller *disabled* in BIOS,
nothing connected. Both channels of onboard HPT-366 enabled. EIDE disk (BIOS
0x80) as the only device on the primary HPT channel. ATAPI CD-RW as the only
device on the secondary HPT channel. Plus great mixture of SCSI disks, SCSI tape
and CD-ROM on Adaptec-29160.

Other observations:
	- WinXP Pro do not have any problem with this config
	- kernel 2.4.18-0.8 boots and works well
	- kernel 2.4.18-0.16 is not the first release that does not 	boot. Two or more
previous beta kernels exhibit the same bug.
	- No problems with the same -0.16 kernel on two P2B MoBo based machines.
	- Have played with various BIOS settings to N/A (but have not tried the primary
IDE because of no device is connected)
	- When the system hangs, the IDE LED instantly emits light.
	- The hanged-up system can be rebooted with <Ctrl><Alt><Del>
	- Cold of warm reboot does not make any difference, kernel always hangs

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try on similarly configured BP6 MoBo system
2. Maybe disabling the primary IDE controller (both channels) is important.
3.
	

Actual Results:  Kernel hangs during boot, as described above.

Expected Results:  Kernel should boot, just like -0.8 does. :-)

Additional info:


Partition check:
hda:

No [PTBL] printer, kernel hangs.
Comment 1 Arjan van de Ven 2002-04-09 04:56:40 EDT
Please try 2.4.18-0.18 once it hits rawhide (should be in a few hours or so
hopefully); it has some massive hpt366 changes in the hope of fixing this.
Comment 2 Need Real Name 2002-04-09 05:53:47 EDT
OK, I will give it a try and report results.
Comment 3 Need Real Name 2002-04-10 08:19:49 EDT
2.4.18-0.18 report: system (bigmem-i686) boots up normally (only /boot is on IDE
disk, the rest of the system is on SCSI disk.

Then passes the
	dd if=/dev/hda of=/dev/null bs=16k
test

But with
	dd if=/dev/hda of=/dev/null ns=512&
	dd if=/dev/hda of=/dev/null bs=2068&
	dd if=/dev/hda of=/dev/null bs=5120
I have ended with non-responsive multiscreens and the third dd not abortable by
keyboard.

Some errors were reported, but too quickly to be readable and there was no
response to <Control><S>.

Unfortunately, I can't perform write and/or filesystem access test on /dev/hda,
because of I have only small /boot partition on hda and the rest of disk is
occupied by 


2.4.18-0.8 passes the dd stress test w/o any problem.

The test machine is in good condition and un use since mid-2000 w/o any problem.

I am considering to take empty EIDE disk from my work and connect it to the test
machine and the perform filesystem read/write test on this scratch disk.

Brgds,

Ed
Comment 4 Need Real Name 2002-04-10 13:01:02 EDT
Just downloaded -19 kernel. Will test later this evening and report results
tomorrow morning of my GMT+1 time.

Ed
Comment 5 Need Real Name 2002-04-11 04:51:01 EDT
Situation has improved with -0.19 kernel. It boots OK and has passed the "3dd
read-only stress" test about 3 times w/o noticeable problems with the following
settings:
		hdparm -S243 -c3 -m16 -W0 -A0 -d1 -u1 -k1 /dev/hda
Just curious what has changed between -0.18 and -0.19 in this area?

I did not get enough spare time to arrange for the filesystem R/W test.

Ed
Comment 6 Arjan van de Ven 2002-04-12 08:31:13 EDT
We've added some ide updates... probably good ones ;)
Anyway closing this as "fixed in rawhide"; if this comes back please reopen
Comment 7 Need Real Name 2002-04-12 18:20:43 EDT
Just downloading -0.21 for testing. Will report on Monday in case of any HPT
related problems with -0.21.

Brgds,

Ed

Note You need to log in before you can comment on or make changes to this bug.