Bug 630226 - SELinux AVCs for mdadm
SELinux AVCs for mdadm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-09-04 02:08 EDT by Bruno Wolff III
Modified: 2010-10-01 13:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-01 13:48:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2010-09-04 02:08:27 EDT
Description of problem:
type=1400 audit(1283578998.654:5): avc:  denied  { read } for  pid=823 comm="mdadm" name="/" dev=autofs ino=9524 scontext=system_u:system_r:mdadm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:autofs_t:s0 tclass=dir
ppdev: user-space parallel port driver
type=1400 audit(1283578998.785:6): avc:  denied  { getattr } for  pid=826 comm="mdadm" path="/dev/hugepages" dev=hugetlbfs ino=9779 scontext=system_u:system_r:mdadm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hugetlbfs_t:s0 tclass=dir
type=1400 audit(1283578998.786:7): avc:  denied  { read } for  pid=823 comm="mdadm" name="/" dev=hugetlbfs ino=9779 scontext=system_u:system_r:mdadm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hugetlbfs_t:s0 tclass=dir
type=1400 audit(1283578998.786:8): avc:  denied  { open } for  pid=823 comm="mdadm" name="/" dev=hugetlbfs ino=9779 scontext=system_u:system_r:mdadm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hugetlbfs_t:s0 tclass=dir
type=1400 audit(1283578999.004:9): avc:  denied  { read } for  pid=823 comm="mdadm" name="md-device-map" dev=devtmpfs ino=7039 scontext=system_u:system_r:mdadm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:device_t:s0 tclass=file
type=1400 audit(1283578999.010:10): avc:  denied  { open } for  pid=823 comm="mdadm" name="md-device-map" dev=devtmpfs ino=7039 scontext=system_u:system_r:mdadm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:device_t:s0 tclass=file
nmcli used greatest stack depth: 5500 bytes left
type=1400 audit(1283579008.323:11): avc:  denied  { read } for  pid=972 comm="mdadm" name="md-device-map" dev=devtmpfs ino=7039 scontext=system_u:system_r:mdadm_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=file
type=1400 audit(1283579008.329:12): avc:  denied  { open } for  pid=972 comm="mdadm" name="md-device-map" dev=devtmpfs ino=7039 scontext=system_u:system_r:mdadm_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=file


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bruno Wolff III 2010-09-04 04:30:47 EDT
I believe this qualifies as an F14 blocker under:
In most cases, there must be no SELinux 'AVC: denied' messages or abrt crash notifications on initial boot and subsequent login (see Blocker_Bug_FAQ)
Comment 2 Bruno Wolff III 2010-09-08 13:55:46 EDT
It looks like this is fixed by selinux-policy-3.9.3-1.fc14.
After installing it and rebooting I didn't see the AVCs any more.
Comment 3 Adam Williamson 2010-10-01 13:48:35 EDT
current stable selinux-policy is 3.9.5-3, so this should be well fixed by now: closing. Bruno, please re-open if you're still seeing this. Thanks!

Note You need to log in before you can comment on or make changes to this bug.