Bug 63023 - Unable to generate Makefiles for QT examples
Unable to generate Makefiles for QT examples
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: qt (Show other bugs)
skipjack-beta2
i386 Linux
low Severity low
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-09 09:22 EDT by Hugo Varotto
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 09:18:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hugo Varotto 2002-04-09 09:22:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
Every time I try to generate a Makefile using qmake for an example from the QT 3
library, I get errors similar to the following:

[root@hal splitter]# make
Some of the required modules (medium-config) are not available.
Skipped.



A trace of what I did is:

[hvarotto@hal examples]$ pwd
/usr/lib/qt3/doc/examples
[hvarotto@hal examples]$ echo $QTDIR
/usr/lib/qt3
[hvarotto@hal examples]$ ls
aclock        demo          hello         mdi          qfd            sound    
 tooltip
action        desktop       helpviewer    menu         qmag           splitter 
 trayicon
addressbook   dirview       i18n          movies       qtl            sql        tux
application   dragdrop      iconview      network      qwerty         tabdialog
 widgets
biff          drawdemo      layout        opengl       rangecontrols  table    
 wizard
buttongroups  drawlines     life          picture      README         tablet   
 xform
canvas        examples.pro  lineedits     popup        richtext       tetrix     xml
checklists    fileiconview  listbox       process      rot13          textedit
cursor        fonts         listboxcombo  progress     scribble       themes
customlayout  forever       listviews     progressbar  scrollview     thread
dclock        gridview      Makefile      qdir         showimg        tictac
[hvarotto@hal examples]$ cd splitter
[hvarotto@hal splitter]$ ls
Makefile  splitter.cpp  splitter.doc  splitter.pro

[hvarotto@hal splitter]$ su
Password:
[root@hal splitter]# qmake
[root@hal splitter]# make
Some of the required modules (medium-config) are not available.
Skipped.

According to the QT information, QT requires to have a .qmake.cache file
resident at the top level of the QT tree. That file is generated whne the QT
source code is compiled, but that's not included in the released QT with skipjack



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cd /usr/lib/qt3/doc/examples/splitter ( or any other example )
2.su
3.qmake
4.make
	

Actual Results:  "Some of the required modules (medium-config) are not available.
Skipped."

This is a message contained in the Makefile. The reason is that wmake was not
abe to generate a meaningful Makefile.


Expected Results:  The compilation whould have been started

Additional info:

I'll mark this bug severity as HIGH, 'cause it seems that it's not posible to
compile any QT program at all. I had to copy a .qmake.cache file from another
machine to make the compilation succeed.

skipjack2 was installed from scratch ( no upgrade done, partition was
reformatted ). Options selected when installed was Laptop installation, KDE,
Development.
Comment 1 Bernhard Rosenkraenzer 2002-04-10 09:08:50 EDT
Wrong.   
This affects *only* the Qt examples.   
Nothing should REQUIRE=medium-config unless it expects to be built inside the Qt source   
tree.  
 
The fix is to remove the REQUIRE= line from the examples Makefiles. Reducing priority 
because that's hardly critical (but should be done anyway). 
Comment 2 Bernhard Rosenkraenzer 2002-04-11 10:49:52 EDT
Fixed in 3.0.0-9

Note You need to log in before you can comment on or make changes to this bug.