Bug 630266 - (ghc-JSONb) Review Request: ghc-JSONb - JSON parser that uses byte strings
Review Request: ghc-JSONb - JSON parser that uses byte strings
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
NotReady
:
Depends On: 630260 630261 630264
Blocks: ghc-data-object-json
  Show dependency treegraph
 
Reported: 2010-09-04 10:14 EDT by Ben Boeckel
Modified: 2013-07-09 23:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 06:26:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Boeckel 2010-09-04 10:14:35 EDT
Spec URL: http://benboeckel.net/packaging/ghc-JSONb/ghc-JSONb.spec
SRPM URL: http://benboeckel.net/packaging/ghc-JSONb/ghc-JSONb-1.0.2-1.fc14.src.rpm
Description:
This parser consumes lazy ByteStrings to produce JSON in a
simple, efficient format backed with strict ByteStrings,
Rationals and ByteString tries.

% lintmock fedora-14-x86_64-bb
ghc-JSONb.src: W: strange-permission JSONb-1.0.2.tar.gz 0640L
ghc-JSONb.src: W: strange-permission ghc-JSONb.spec 0640L
ghc-JSONb-prof.x86_64: E: devel-dependency ghc-JSONb-devel
ghc-JSONb-prof.x86_64: W: no-documentation
ghc-JSONb-prof.x86_64: W: devel-file-in-non-devel-package /usr/lib64/ghc-6.12.3/JSONb-1.0.2/libHSJSONb-1.0.2_p.a
4 packages and 0 specfiles checked; 1 errors, 4 warnings.
Comment 1 Ben Boeckel 2012-03-02 21:38:48 EST
Spec URL: http://benboeckel.net/packaging/ghc-JSONb/ghc-JSONb.spec
SRPM URL: http://benboeckel.net/packaging/ghc-JSONb/ghc-JSONb-1.0.8-1.fc18.src.rpm

ghc-JSONb.src: W: strange-permission JSONb-1.0.8.tar.gz 0640L
ghc-JSONb.src: W: strange-permission ghc-JSONb.spec 0640L
3 packages and 0 specfiles checked; 0 errors, 2 warnings.
Comment 2 Jens Petersen 2013-06-24 06:26:31 EDT
Closing out old Haskell Package Reviews that use deprecated macros
like %ghc_devel_package, etc, which are no longer available in F20 Rawhide.  Please update your package using cabal-rpm-0.8.x or later and re-open
or file a new Review Request.  Thanks!
Comment 3 Ben Boeckel 2013-07-09 23:08:19 EDT
Upstream indicates that aeson should be used instead.

Note You need to log in before you can comment on or make changes to this bug.