Bug 630328 - Completion for RPM disables filename completion.
Summary: Completion for RPM disables filename completion.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bash-completion
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-04 20:07 UTC by Björn Persson
Modified: 2010-10-25 16:34 UTC (History)
2 users (show)

Fixed In Version: bash-completion-1.2-4.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-17 04:51:14 UTC


Attachments (Terms of Use)

Description Björn Persson 2010-09-04 20:07:33 UTC
Description of problem:
When bash-completion is installed, Bash won't complete filenames in rpm commands.

Version-Release number of selected component (if applicable):
bash-completion-1.2-2.fc13.noarch

How reproducible:
Always.

Steps to Reproduce:
rpm --query --file /e<tab>

Actual results:
Nothing happens.

Expected results:
"/e" should be completed as "/etc/" as no other files in the root directory start with e.

Additional info:
Deleting /etc/bash_completion.d/rpm and starting a new shell makes filename completion work again.

Comment 1 Ville Skyttä 2010-09-04 20:46:24 UTC
The problem is that the --file option (ditto --group and --package) is not treated properly, will take a look at fixing it upstream.  Use -f instead of --file to work around it in the meantime.

Comment 3 Fedora Update System 2010-10-03 21:53:55 UTC
bash-completion-1.2-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bash-completion-1.2-3.fc14

Comment 4 Fedora Update System 2010-10-03 22:06:11 UTC
bash-completion-1.2-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/bash-completion-1.2-3.fc13

Comment 5 Fedora Update System 2010-10-04 17:28:04 UTC
bash-completion-1.2-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/bash-completion-1.2-3.el5

Comment 6 Fedora Update System 2010-10-05 09:31:35 UTC
bash-completion-1.2-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bash-completion'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/bash-completion-1.2-3.fc13

Comment 7 Fedora Update System 2010-10-06 20:43:38 UTC
bash-completion-1.2-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-10-17 04:51:01 UTC
bash-completion-1.2-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-10-25 16:34:37 UTC
bash-completion-1.2-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.