Bug 63035 - VNC locks not being deleted during system startup (rc.sysinit)
VNC locks not being deleted during system startup (rc.sysinit)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-04-09 11:19 EDT by Richard Black
Modified: 2014-03-16 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 18:08:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Black 2002-04-09 11:19:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; compaq)

Description of problem:
The VNC locks are not being deleted during system startup 
(/etc/rc.d/rc.sysinit).  After a crash, vnc will not load any more until the 
locks are manually deleted.  The locks should be removed at startup because no 
VNC session should be running yet.  Usage of /etc/sysconfig/vncservers is 
difficult without removal of the VNC locks.  I suggest removal of the VNC locks 
be placed next to removal of X locks in rc.sysinit.

# Delete X locks
rm -f /tmp/.X*-lock

# Delete VNC locks
rm -rf /tmp/.X*-unix

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Reproducible either using /etc/sysconfig/vncservers or just running vncserver 
manually.
1. Set up an entry in /etc/sysconfig/vncservers: VNCSERVERS="1:root"
2. Reboot, notice that a vncserver will be started for DISPLAY #1.
3. Hard Power Off or kill the vncserver so that it does not get a chance to 
remove its vnc lock in /tmp (kill -9 [pid of vncserver]).
4. Boot the system.

	

Actual Results:  The VNC lock still exists and will not allow vncserver to 
start.  The VNC lock must be removed manually before a vncserver session can be 
started on that display again.

Expected Results:  The VNC lock should have been deleted during bootup so 
that /etc/rc.d/init.d/vncserver could have started the vncserver session.

Additional info:
This also appears in RH72.
Comment 1 Bill Nottingham 2002-04-10 01:35:33 EDT
fixed in 6.62-1

Note You need to log in before you can comment on or make changes to this bug.