Bug 63042 - triggering xinetd hard reconfiguration with chkconfig
triggering xinetd hard reconfiguration with chkconfig
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: xinetd (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-09 11:48 EDT by Michael Schwendt
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 19:15:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-04-09 11:48:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
With Enigma and earlier, one could toggle xinetd maintained services with just
chkconfig. "chkconfig wu-ftpd on" would not just create the proper links for the
current run-level, but would also send a USR2 signal to xinetd, causing a hard
reconfiguration and wu-ftpd being enabled. The exact opposite would happen for
"chkconfig wu-ftpd off". It would create the run-level link and signal xinetd to
re-read its config, stopping listening on the wu-ftpd port.

Besides the change from SIGUSR2 to SIGHUP, I see a major (still undocumented)
difference on Skipjack beta2.  "chkconfig wu-ftpd on" does NOT signal xinetd to
re-read its config. But "chkconfig wu-ftpd off" still does. Unless this is a
bug, it should be documented somewhere (the documentation for Enigma was wrong),
that "chkconfig wu-ftpd on" is not the opposite of "chkconfig wu-ftpd off" and
probably other xinetd maintained services:

# service xinetd status   
xinetd (pid 2337) is running...
# chkconfig --list wu-ftpd
wu-ftpd         off
# chkconfig wu-ftpd on
[log: xinetd: xinetd -HUP succeeded]
# chkconfig --list wu-ftpd
wu-ftpd         on
# socklist | grep xinetd

At this point -- unlike Enigma or earlier -- xinetd would not listen on ftp port
yet.

# service xinetd restart
[log: xinetd: xinetd shutdown succeeded
xinetd[2462]: xinetd Version 2002.03.26 started with libwrap options compiled in.
xinetd[2462]: Started working: 1 available service
xinetd: xinetd startup succeeded]
# socklist | grep xinetd
tcp     21      13110       0   2462    5  xinetd

This disables and stops it:

# chkconfig wu-ftpd off
[log: xinetd[2462]: Starting reconfiguration
xinetd[2462]: service ftp deactivated
xinetd[2462]: Reconfigured: new=0 old=0 dropped=1 (services)
xinetd: xinetd -HUP succeeded]
# socklist | grep xinetd
#

This enables it, but doesn't turn it on:

# chkconfig wu-ftpd on 
[log: xinetd: xinetd -HUP succeeded]
# socklist | grep xinetd
#


Version-Release number of selected component (if applicable):
xinetd 2.3.4-0.6 (plus chkconfig 1.3.4-1)

How reproducible:
Always
Comment 1 Trond Eivind Glomsrxd 2002-04-09 12:43:45 EDT
It didn't send signals, but it does exec '/etc/inet.d/xinetd reload'.
Comment 2 Trond Eivind Glomsrxd 2002-04-09 12:48:31 EDT
Signal seems to be sent... taking back the bug :)
Comment 3 Trond Eivind Glomsrxd 2002-04-10 17:08:14 EDT
Confirmed as working on two systems, with xinetd-2.3.4-0.7 and xinetd-2.3.4-0.8.
No changes in that part.
Comment 4 Michael Schwendt 2002-04-10 17:40:28 EDT
Verified.

# rpm -q xinetd
xinetd-2.3.4-0.8
Comment 5 Michael Schwendt 2002-04-10 19:16:34 EDT
It's patch1 that fixes this bug.

Note You need to log in before you can comment on or make changes to this bug.