Bug 63047 - Kernel Source for Alternate Binary Format Modules broken
Summary: Kernel Source for Alternate Binary Format Modules broken
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-09 16:07 UTC by Mark Lane
Modified: 2007-04-18 16:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 17:44:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Lane 2002-04-09 16:07:25 UTC
Description of Problem:
On make modules, sysinfo.c has errors. One appears to be a typo in a 
header file (compile.h instead of compiler.h) but even after that was fixed I still got an 
error.

Version-Release number of selected component (if applicable):
Kernel-Source-
2.4.18 from Slipjack 7.2.93

How Reproducible:
Everytime

Steps to Reproduce:
1. 
for example copy configs/kernel-2.4.18-athlon.config .config; Make oldconfig
2. make 
deps
3. make modules

Actual Results:
won't compile abi/svr4/sysinfo.c

Expected 
Results:
It will compile abi/svr4/sysinfo.c


Additional Information:
I just 
disabled the modules and recompiled but some people with want them.

Comment 1 Arjan van de Ven 2002-04-10 14:23:04 UTC
Ok the issues seems to be that you didn't do a "make bzImage" before doing make
modules. technically it is required, but only few modules actually compile-time
depend on it (runtime depend they do!)....

Comment 2 Mark Lane 2002-04-10 17:44:49 UTC
Yes, I made bzImage before modules and it compiled fine.


Note You need to log in before you can comment on or make changes to this bug.