Bug 630490 - disabled units still get bus activated
disabled units still get bus activated
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-09-05 19:44 EDT by Rahul Sundaram
Modified: 2010-09-14 19:26 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-14 19:26:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
systemctl dump output on my system (393.69 KB, text/plain)
2010-09-06 02:21 EDT, Rahul Sundaram
no flags Details

  None (edit)
Description Rahul Sundaram 2010-09-05 19:44:01 EDT
Description of problem:

I disable NetworkManager and it still gets bus activated

Version-Release number of selected component (if applicable):

systemd-9-3.fc14.x86_64


How reproducible:

everytime

Steps to Reproduce:
1. systemctl disable NetworkManager.service

rm '/etc/systemd/system/dbus-org.freedesktop.NetworkManager.service'
rm '/etc/systemd/system/network.target.wants/NetworkManager.service'
rm '/etc/systemd/system/multi-user.target.wants/NetworkManager.service'

2.  start pidgin or thunderbird
3.  watch NM get started automatically
  
Actual results:

NM gets bus activated even if explicitly stopped and disabled

Expected results:

If I manually run systemctl stop NetworkManager.service, I don't really want it auto activated at all.  I prefer to not run disable because it disable it permanently while I just want it to stopped for the current session only.  Even still,  I run systemctl disable NetworkManager.service and it still gets bus activated
Comment 1 Lennart Poettering 2010-09-05 20:06:30 EDT
Please provide the output of "systemctl dump" after you disabled it.
Comment 2 Rahul Sundaram 2010-09-06 02:21:48 EDT
Created attachment 443234 [details]
systemctl dump output on my system
Comment 3 Lennart Poettering 2010-09-06 04:57:17 EDT
Args, I know what is wrong.
Comment 4 Marcela Mašláňová 2010-09-06 08:59:30 EDT
I don't use NetworkManager on computer, which doesn't have wifi. What's the correct way of disabling NetworkManager?

I've tried:
systemctl disable NetworkManager.service
systemctl enable network.target (because this doesn't have service)

After reboot:
systemctl | grep etwork
NetworkManager.service loaded active running
network.target loaded active active

I suppose there's missing on network.service.
Comment 5 Adam Williamson 2010-09-10 12:41:23 EDT
This was discussed at the blocker review meeting of 2010-09-10. We agreed that we would like to accept this bug as a blocker but it does not meet any existing release criterion. We would have to draft a new criterion or set up some integration between the feature and blocker processes to really cover this. (It doesn't even fit in the cop-out paragraph, because we can't reasonably characterize it as a High severity bug: it doesn't make systemd unusable).

For now we will leave it on F14Beta but not mark it as AcceptedBlocker, and try to refine the process. Obviously, it would be best to fix it ASAP regardless :)
Comment 6 Lennart Poettering 2010-09-10 19:32:30 EDT
Fixed now in git upstream. Upload will follow shortly.
Comment 7 John Poelstra 2010-09-13 18:37:02 EDT
(In reply to comment #6)
> Fixed now in git upstream. Upload will follow shortly.

Great to hear.  When will we have a new package in Fedora?
Comment 8 Bill Nottingham 2010-09-14 00:56:42 EDT
This is not fixed in 10-1, at least not for the case of NetworkManager.
Comment 9 Lennart Poettering 2010-09-14 07:33:11 EDT
Hm,, this really should be fixed. Are you sure this is still borked? I cannot believe this problem remains, because the code previously responsible for this I removed in its entirety...

Bill, could you please attach "systemctl show Networkmanager.service"?
Comment 10 Rahul Sundaram 2010-09-14 10:56:58 EDT
rpm -q systemd initscripts

systemd-10-1.fc14.x86_64
initscripts-9.20-1.fc14.x86_6

--

After the update, the problem is fixed for me. Thanks.  Was such a annoyance.
Comment 11 Bill Nottingham 2010-09-14 11:09:17 EDT
(In reply to comment #9)
> Hm,, this really should be fixed. Are you sure this is still borked? I cannot
> believe this problem remains, because the code previously responsible for this
> I removed in its entirety...
> 
> Bill, could you please attach "systemctl show Networkmanager.service"?

Well, I've done some more testing... there were still some stray symlinks listing NM as enabled; once those are removed, 'nmcli' no longer starts NM itself.

I still find the behavior pretty odd that 'nmcli nm status' causes networking to start completely,if NM is configured to start on boot but hasn't started yet.
Comment 12 Adam Williamson 2010-09-14 15:10:03 EDT
setting back to MODIFIED based on the above.

Note You need to log in before you can comment on or make changes to this bug.