Bug 630492 - SELinux is preventing /usr/bin/pulseaudio "lock" access on /root/.esd_auth.
Summary: SELinux is preventing /usr/bin/pulseaudio "lock" access on /root/.esd_auth.
Keywords:
Status: CLOSED DUPLICATE of bug 543970
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:2e831215083...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-06 00:54 UTC by Donald Cohen
Modified: 2010-09-08 07:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-08 07:41:01 UTC


Attachments (Terms of Use)

Description Donald Cohen 2010-09-06 00:54:30 UTC
Summary:

SELinux is preventing /usr/bin/pulseaudio "lock" access on /root/.esd_auth.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by pulseaudio. It is not expected that this
access is required by pulseaudio and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:pulseaudio_t:s0
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                /root/.esd_auth [ file ]
Source                        pulseaudio
Source Path                   /usr/bin/pulseaudio
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           pulseaudio-0.9.21-5.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-121.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux number11.don-eve.dyndns.org
                              2.6.32.21-166.fc12.x86_64 #1 SMP Fri Aug 27
                              06:07:37 UTC 2010 x86_64 x86_64
Alert Count                   9
First Seen                    Sat 12 Jun 2010 11:36:35 AM PDT
Last Seen                     Sat 04 Sep 2010 11:51:28 AM PDT
Local ID                      f077c2e6-de1b-4066-9050-a4f7564ab53c
Line Numbers                  

Raw Audit Messages            

node=number11.don-eve.dyndns.org type=AVC msg=audit(1283626288.384:7): avc:  denied  { lock } for  pid=1709 comm="pulseaudio" path="/root/.esd_auth" dev=dm-0 ino=3915903 scontext=system_u:system_r:pulseaudio_t:s0 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file

node=number11.don-eve.dyndns.org type=SYSCALL msg=audit(1283626288.384:7): arch=c000003e syscall=72 success=yes exit=0 a0=1d a1=7 a2=7fff8c6cd8f0 a3=fffffff7 items=0 ppid=1684 pid=1709 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="pulseaudio" exe="/usr/bin/pulseaudio" subj=system_u:system_r:pulseaudio_t:s0 key=(null)



Hash String generated from  catchall,pulseaudio,pulseaudio_t,admin_home_t,file,lock
audit2allow suggests:

#============= pulseaudio_t ==============
allow pulseaudio_t admin_home_t:file lock;

Comment 1 Miroslav Grepl 2010-09-06 10:46:58 UTC
Did you log in as a root user?

Comment 2 Donald Cohen 2010-09-06 16:31:04 UTC
Yes, is there some reason root should not use audio?

Comment 3 Daniel Walsh 2010-09-07 18:51:40 UTC
Are you logged in as X as root?

Comment 4 Donald Cohen 2010-09-07 19:14:05 UTC
(In reply to comment #3)
> Are you logged in as X as root?

Yes.  Why should that be a problem?

Comment 5 Miroslav Grepl 2010-09-08 07:41:01 UTC
Logging in directly as root from X Windows is not supported with SELinux,  It
is considered too dangerous and the amount/type of policy that would needed to
be written, would allow too much access.

*** This bug has been marked as a duplicate of bug 543970 ***


Note You need to log in before you can comment on or make changes to this bug.