Bug 6305 - if filesystem is full gdm fails to login users without warning
Summary: if filesystem is full gdm fails to login users without warning
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm   
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-24 15:16 UTC by bastiaan
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 17:28:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bastiaan 1999-10-24 15:16:25 UTC
If the file system is full, users cannot login via gpm: the
system tries to start an X session, but fails and returns to
the login window. The user is not informed what causes the
failure.

Comment 1 Havoc Pennington 2000-02-03 21:37:59 UTC
The problem here is gdm lacks any facility to display errors or dialogs
of any kind, it only logs them to syslog. It's a large fix that's required.

Comment 2 Havoc Pennington 2000-02-17 17:28:59 UTC
I looked into fixing this more; the problem is actually worse than I thought.
gdm can display errors, up until it exec's your session. After that it's
hard to know what to do; gdm isn't running out of space I don't think, I think
the apps launched in .Xclients are running out of space. At that point gdm
is out of the picture. So, this bug is actually "many apps have
bad error handling" I don't think it's a gdm bug.

Comment 3 Havoc Pennington 2001-07-06 03:01:44 UTC
This problem is basically unfixable since it's so general; specific bugs against
specific apps would be required.


Note You need to log in before you can comment on or make changes to this bug.