Bug 630539 - perl-DBIx-Class FTBFS (0.08120 possibly incompatible with perl-SQL-Abstract-1.67)
perl-DBIx-Class FTBFS (0.08120 possibly incompatible with perl-SQL-Abstract-1...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-DBIx-Class (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Iain Arnell
Fedora Extras Quality Assurance
:
: 631078 (view as bug list)
Depends On: perl-Math-Base36
Blocks: F14FTBFS
  Show dependency treegraph
 
Reported: 2010-09-06 03:06 EDT by Mark Chappell
Modified: 2010-09-09 10:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-09 10:52:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Scratch build logs (393.44 KB, text/html)
2010-09-06 03:06 EDT, Mark Chappell
no flags Details

  None (edit)
Description Mark Chappell 2010-09-06 03:06:49 EDT
Created attachment 443240 [details]
Scratch build logs

Description of problem:

perl-DBIx-Class currently fails to build from source due to failing tests.

#   Failed test at t/bind/order_by.t line 47.
# died: DBIx::Class::ResultSet::as_query(): [SQL::Abstract::_assert_bindval_matches_bindtype] Fatal: bindtype 'columns' selected, you need to pass: [column_name => bind_value] at t/bind/order_by.t line 43
#   Failed test 'Fail the unfinished is_same_sql_bind'
#   at t/bind/order_by.t line 48.
#   Failed test at t/bind/order_by.t line 47.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=584391
Seems to suggest that this is due to the recent version increment in perl-SQL-Abstract which means that we need to bump up to at least 0.08122.

Latest version available is 0.08123

Version-Release number of selected component (if applicable):
0.08120
Comment 1 Iain Arnell 2010-09-06 03:18:54 EDT
I've already prepared an update to 0.08123 - but it's blocked waiting for new perl-Math-Base36 package to be reviewed.
Comment 2 Iain Arnell 2010-09-07 17:23:59 EDT
*** Bug 631078 has been marked as a duplicate of this bug. ***
Comment 3 Iain Arnell 2010-09-09 10:52:34 EDT
Updated to 0.08123 in rawhide (el6 coming soon)

http://koji.fedoraproject.org/koji/buildinfo?buildID=194517

Note You need to log in before you can comment on or make changes to this bug.