Bug 63055 - Apply patch to samba allowing 'winbind use default domain'
Summary: Apply patch to samba allowing 'winbind use default domain'
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: samba (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-09 17:29 UTC by eeeg
Modified: 2007-03-27 03:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-17 21:54:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description eeeg 2002-04-09 17:29:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Alexander Bokovoy wrote a patch for winbind that allows users to just user 
their acct name rather than the Domain+acct name.  It would be nice if Red Hat 
applied it.

I found the patch at:
http://lists.samba.org/pipermail/samba-technical/2001-December/033258.html

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.n/a
2.
3.
	

Additional info:

Comment 1 Trond Eivind Glomsrxd 2002-04-09 20:26:04 UTC
Username overlap?

Comment 2 Andrew Bartlett 2002-04-17 21:54:21 UTC
Username overlap is the same as for ldap/nis/etc

But don't apply the patch - the patch requires a fair bit of work in smbd to
make it function correctly - work that has only been done in HEAD (where this
patch is a standard feature.

Comment 3 Trond Eivind Glomsrxd 2002-04-17 22:40:56 UTC
If the samba developers don't like it, we don't apply it...

Comment 4 Andrew Bartlett 2002-04-23 02:54:33 UTC
Look forward to Samba 3.0, where this will be an offical and supported feature!

(becouse is is really neat, particularly for mail servers etc).

Comment 5 Andrew Bartlett 2002-05-06 10:03:25 UTC
Due to a recent merge of functionaliy from HEAD to 2.2, this option was released
with 2.2.4.  However, it has not been tested, and I'm pretty sure it is broken.  

Furthermore: this breakage might not be immidiatly ovbious - the main issue is
in the SID->name and name->SID calls, not in core operations.

(It was meant to be merged as an undocumented option - but the documentation got
merged just before the release).

Redhat: please don't enable this functionaliy in any kind of setup tool!

Users: You have been warned.

Andrew Bartlett,
Samba Team


Note You need to log in before you can comment on or make changes to this bug.