Bug 63068 - Quanta crashes when attempting to view in browser
Quanta crashes when attempting to view in browser
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: quanta (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-09 15:28 EDT by Gerry Tool
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-20 13:10:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of quanta crash when trying to view page in internal browser (2.59 KB, text/plain)
2002-04-10 09:02 EDT, Gerry Tool
no flags Details

  None (edit)
Description Gerry Tool 2002-04-09 15:28:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
When I load a html file into quanta, selecting the file in the left hand file
tree pane, the lookup process takes a very long time.  When I get to the file,
it loads fine.  As soon as I try to view the file with the view icon in the
toolbar, it views for an instant and then the window closes and 4 (always 4)
windows titled "<name of working directory> - KWrite" open with blank contents.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start quanta 2 pre 2
2.load file (not necessary for problem to occur)
3.click on preview icon in toolbar
	

Actual Results:  preview appears for an instant
window closes
4 instances of KWrite open with the name of the working directory in the title bar.

Expected Results:  browser view of html document should appear until closed by
user to return to editing view

Additional info:

Selecting a file from the file tree in the left pane is very slow - futher down
the tree, the slower it goes.

A file does not need to be loaded for the crash to occur.

I'm surprised that the final release of Quanta 2 is not included - it is
included in Mandrake 8.2 and functions fine there.
Comment 1 Bernhard Rosenkraenzer 2002-04-10 08:17:19 EDT
Works for me...   
  
quanta-2.1-0.cvs20020405.1  
kdelibs-3.0.0-8debug  
kdebase-3.0.0-4  
 
We aren't shipping 2.0 final (or 2.0.1) because it doesn't work with KDE3, the version 
we're shipping is a fixed CVS of 2.1.
Comment 2 Bernhard Rosenkraenzer 2002-04-10 08:18:21 EDT
(We're taking the version from KDE CVS, not from Sourceforge CVS).
Comment 3 Gerry Tool 2002-04-10 09:02:33 EDT
Created attachment 53064 [details]
backtrace of quanta crash when trying to view page in internal browser
Comment 4 Gerry Tool 2002-04-10 09:05:29 EDT
I didn't specify originally that I was trying to use the _internal_ browser when
the crash occurs.  I get the feeling from your comments that the version of
Quanta to be included in the final release is different than the one I'm trying
to use in beta 2.  Just in case it is the same, I just included a backtrace of
my crash.
Comment 5 Joshua 2002-04-12 19:32:41 EDT
It does not work for me. Although, the preview does work now, since the recent
up of kdebase - etc., navigating tree view, file open and project open cause
almost 100% CPU usage as quanta hangs for about 20 seconds or longer. It does
not crash but it is an un-usable application in it's current state.
Comment 6 Gerry Tool 2002-04-13 00:01:11 EDT
I agree with the comment from josh@wavefood.com.  The program does now function,
and the internal browser view icon works, but the loading of a file from the
left navigation pane is _painfully_ slow, getting slower and slower as one moves
down the directory tree.  I see from the quanta.sourceforge.net site that the
KDE 3 effort appears aimed at added features.  If you have any way to sway them,
please get them to make it work with KDE 3 as it now does with KDE 2.2 before
adding more features.  I have contacted them with a request to do so.
Comment 7 Ngo Than 2003-07-20 13:10:12 EDT
it's fixed in quanta 3. which is included in RHL 3

Note You need to log in before you can comment on or make changes to this bug.