Bug 63074 - Kernel Panic after installer detects Promise Ultra66 PCI card
Kernel Panic after installer detects Promise Ultra66 PCI card
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-09 16:22 EDT by Tuan Hoang
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 13:48:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tuan Hoang 2002-04-09 16:22:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4.1)
Gecko/20020314 Netscape6/6.2.2

Description of problem:
I have an old Pentium 166 (no MMX) board with an Intel 430HX chipset and 128MB
RAM.  I have 3 hard drives (2GB, 1GB, 1.2GB) on a retail Promise Ultra66 PCI
controller card.  The CD-ROM is actually a Toshiba 6x DVD-ROM connected to the
primary IDE on the board.  

All CD images have been verified and I'm using a boot floppy to install.  The
installer detects the controller and then starts to enumerate them.  I get a
kernel panic after installer detects Promise Ultra66 PCI card.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Have CD1 and boot floppy in the machine.
2. Boot the machine and then the installer.
3. Kernel panics after detecting the Promise Ultra66 controller.
	

Actual Results:  Kernel Panic after installer detects Promise Ultra66 PCI card

Expected Results:  Installer should have worked.

Additional info:

All the hardware is working as expected.  I even installed WinXP Pro on there
just to make sure.  It's all working...albeit painfully slow...more of a reason
to get Linux on there.  ;)
Comment 1 Tuan Hoang 2002-04-10 15:34:40 EDT
I have also successfully installed FreeBSD 4.5 on this machine.
Red Hat 7.2 installer locks up after enumerating the drive controllers
and Red Hat 7.2.93 (skipjack-beta2) gets a kernel panic immediately
when booting the installer.
Comment 2 Arjan van de Ven 2002-04-11 08:46:53 EDT
I just dusted off my fasttrak 66PCI and it installed fine with the 2.4.18-0.18
kernel. Can you give any more info on the "panic" ?
Any messages on the console ?
Comment 3 Tuan Hoang 2002-04-11 09:57:01 EDT
Not sure what happened but it no longer panics (Oops), just locks up.
(Perhaps FreeBSD 4.5 reconfigured some card.)  Also the card is an Ultra66
not the FastTrak66.

This is what happens during booting off a floppy (the BIOS doesn't like RH CD's):
- Detects on-board IDE controller ide0 & ide1
- Detects Promise Ultra66 (PDC20262) IDE controller
- Enumerates:
ide2: BM-DMA at 0x6500-0x6507 hde=pio, hdf=pio
ide3: BM-DMA at 0x6508-0x650f hdg=pio, hdh=pio
hda = TOSHIBA DVD-ROM SD-M1212, ... (6x DVD-ROM)
hde = MAXTOR 72004 AP, ... (2.0GB IDE)
hdg = WDC AC2100H, ... (1.0GB IDE)
hdh = WDC AC31200F, ... (1.2GB IDE)
ide0 at 0x1f0-0x1f7, 0x3f6 on IRQ 14
ide2 at 0x6100-0x6107, 0x6202 on IRQ 11
ide3 at 0x6300-0x6307, 0x6402 on IRQ 11
blk: queue c02cef2c, I/O limit 4096Mb (mask 0xffffffff)

Then it just sits there and the box is locked hard.
Can't use CTRL+ALT+DEL; requires RESET or POWER cycle.

Comment 4 Tuan Hoang 2002-05-10 08:26:42 EDT
Turns out that the Promise Ultra66 doesn't like the old 2GB Maxtor drive.  I
moved that to the on-board controller and things worked fine.  FWIW, Red Hat 7.2
installs fine on it too.  You can close this if it even makes sense since 7.3 is
out already.

Note You need to log in before you can comment on or make changes to this bug.