Bug 631015 - Broken evo update path
Broken evo update path
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-09-07 11:49 EDT by Nicolas Mailhot
Modified: 2010-10-04 18:09 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-2.32.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-04 18:09:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-09-07 11:49:40 EDT
Description of problem:
yum update -y
Loaded plugins: downloadonly, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libedataserverui-1.2.so.10()(64bit) for package: evolution-2.31.90-1.fc14.x86_64
--> Processing Dependency: libedataserverui-1.2.so.10()(64bit) for package: gnome-panel-2.31.90-1.fc14.x86_64
---> Package evolution-data-server.x86_64 0:2.31.91-1.fc14 set to be updated
--> Processing Dependency: libmodman.so.0()(64bit) for package: libproxy-0.4.4-7.fc14.x86_64
---> Package libmodman.x86_64 0:2.0.0-1.fc14 set to be updated
--> Finished Dependency Resolution
Error: Package: evolution-2.31.90-1.fc14.x86_64 (@/evolution-2.31.90-1.fc14.x86_64)
           Requires: libedataserverui-1.2.so.10()(64bit)
           Removing: evolution-data-server-2.31.90-1.fc14.x86_64 (@/evolution-data-server-2.31.90-1.fc14.x86_64)
               libedataserverui-1.2.so.10()(64bit)
           Updated By: evolution-data-server-2.31.91-1.fc14.x86_64 (koji-f14-builds)
               Not found
Error: Package: libproxy-0.4.4-7.fc14.x86_64 (@koji-f14-builds)
           Requires: libmodman.so.0()(64bit)
           Removing: libmodman-1.0.1-5.fc14.x86_64 (@koji-f14-builds)
               libmodman.so.0()(64bit)
           Updated By: libmodman-2.0.0-1.fc14.x86_64 (updates-testing)
               Not found
Error: Package: gnome-panel-2.31.90-1.fc14.x86_64 (@/gnome-panel-2.31.90-1.fc14.x86_64)
           Requires: libedataserverui-1.2.so.10()(64bit)
           Removing: evolution-data-server-2.31.90-1.fc14.x86_64 (@/evolution-data-server-2.31.90-1.fc14.x86_64)
               libedataserverui-1.2.so.10()(64bit)
           Updated By: evolution-data-server-2.31.91-1.fc14.x86_64 (koji-f14-builds)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):

evolution-perl-2.31.90-1.fc14.x86_64
evolution-2.31.90-1.fc14.x86_64
evolution-data-server-2.31.90-1.fc14.x86_64
evolution-help-2.31.90-1.fc14.noarch
Comment 1 Milan Crha 2010-09-08 05:20:22 EDT
Thanks for a bug report. I didn't finish build of the other packages yet, due to some troubles with a building system. There will be a release of 2.31.92 next week, so I'm wondering whether it'll be easier to just skip 2.31.91 and make the whole process with the newer version.
Comment 2 Matthew Barnes 2010-09-08 08:08:32 EDT
2.31.91 seems held up in updates-testing by testers assigning it negative karma for random, unrelated issues.  At this rate I wonder if we'll ever see another Evolution update reach Fedora stable.
Comment 3 William Makowski 2010-09-25 19:52:17 EDT
I'm experiencing some dependency issues with evolution updates and gnome-panel requirements.  It looks very similar to what was reported above.

[root@pippin ~]# yum -y update
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package evolution.i686 0:2.31.92-1.fc14 set to be updated
--> Processing Dependency: libedataserverui-1.2.so.10 for package: gnome-panel-2.31.90-4.fc14.i686
---> Package evolution-data-server.i686 0:2.31.92-1.fc14 set to be updated
---> Package evolution-help.noarch 0:2.31.92-1.fc14 set to be updated
--> Finished Dependency Resolution
Error: Package: gnome-panel-2.31.90-4.fc14.i686 (@updates-testing)
           Requires: libedataserverui-1.2.so.10
           Removing: evolution-data-server-2.31.90-1.fc14.i686 (@updates-testing)
               libedataserverui-1.2.so.10
           Updated By: evolution-data-server-2.31.92-1.fc14.i686 (updates-testing)
               Not found
           Available: evolution-data-server-2.31.5-1.fc14.i686 (fedora)
               libedataserverui-1.2.so.10
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@pippin ~]#
Comment 4 William Makowski 2010-09-26 10:15:41 EDT
In koji it looks like we need a build of gnome-panel-2.31.92-1.fc15 for fc14. Should I report this against gnome-panel?
Comment 5 Milan Crha 2010-09-27 04:33:01 EDT
I wrote to maintainers and asked them to rebuild their packages with an apologize of a very late notice from my side.
Comment 6 William Makowski 2010-10-02 11:13:52 EDT
Looks like this bug has been resolved with the rebuild of gnome-panel.

Note You need to log in before you can comment on or make changes to this bug.