Bug 63102 - artsbuilder kills machine
Summary: artsbuilder kills machine
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdemultimedia   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61901 67218 79579
TreeView+ depends on / blocked
 
Reported: 2002-04-10 02:21 UTC by Ben Levenson
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-14 14:29:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback after selecting "Execute structure" (2.43 KB, text/plain)
2002-09-05 22:24 UTC, Ben Levenson
no flags Details

Description Ben Levenson 2002-04-10 02:21:47 UTC
Description of Problem:
artsbuilder renders machine useless after a few minutes up and running.

Version-Release number of selected component (if applicable):
kdemultimedia-arts-3.0.0-1

How Reproducible:
100%

Steps to Reproduce:
1. /usr/bin/artsbuilder
2. start 'top' so you can see what it is doing to your system
3. open artsbuilder manual, follow instructions for tutorial
4. hear mega-swapping start to happen at about the second step of tutorial.
5. flip power switch, since nothing else is possible.

I'll try to provide some more useful information....

Comment 1 Bernhard Rosenkraenzer 2002-04-10 09:34:59 UTC
Works for me. 
What soundcard are you using?

Comment 2 Ben Levenson 2002-04-10 17:07:16 UTC
I've reproduced this on 2 different systems:
from lspci -v:
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 04)
        Subsystem: Intel Corp.: Unknown device 4732
        Flags: bus master, medium devsel, latency 0, IRQ 10
        I/O ports at e800 [size=256]
        I/O ports at ef00 [size=64]

and
00:08.0 Multimedia audio controller: S3 Inc. SonicVibes
        Subsystem: Unknown device bfbf:bfbf
        Flags: bus master, medium devsel, latency 32, IRQ 5
        I/O ports at 9c00 [size=16]
        I/O ports at a000 [size=16]
        I/O ports at a400 [size=4]
        I/O ports at a800 [size=4]
        I/O ports at ac00 [size=8]

here are the steps I used to reproduce it on the 2nd system:
1- install, start KDE
2- choose the maximum setting on "Eye-candy-o-meter"
3- open artsbuilder
4- open artsbuilder handbook
5- select and place Modules->Synthesis->SoundIO->Synth_AMAN_PLAY
6- double click on 'title' parameter; select constant value and type tutorial
7- listen to hard disk spin madly, artsbuilder crashes.

Comment 3 Bernhard Rosenkraenzer 2002-04-11 16:08:57 UTC
Still can't reproduce this, it does just what I'd expect. Are you using the current 
packages?

Comment 4 Bernhard Rosenkraenzer 2002-04-11 16:21:50 UTC
Assigning to Than, it seems to happen on his machine as well while it works here.

Comment 5 Ngo Than 2002-07-14 09:51:26 UTC
please try kdemultimedia-arts-3.0.2-1 again. i cannot reproduce it in this release.

Comment 6 Jay Turner 2002-09-04 01:53:31 UTC
benl, will you try to replicate this with the latest packages, as it appears you
have systems which were experiencing the problems.  Please close out the issue
if you no longer are seeing problems.

Comment 7 Ben Levenson 2002-09-05 22:22:45 UTC
I got a little further this time. It didn't render my machine useless, but I 
did get a traceback (attached).

Comment 8 Ben Levenson 2002-09-05 22:24:14 UTC
Created attachment 75144 [details]
traceback after selecting "Execute structure"

Comment 9 Thomas Woerner 2003-02-14 14:29:58 UTC
Fixed in rawhide in rpm arts-1.1-5 or newer.

All kde packages, which are using libmcop (provided by arts) have to be upgraded
to the latest version. These packages are: kdelibs, kdebase, kdemultimedia,
kdeaddons, kdegames and koffice.


Note You need to log in before you can comment on or make changes to this bug.