Bug 6311 - Several bash things are hosed
Several bash things are hosed
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-24 14:47 EDT by alanf
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 12:25:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alanf 1999-10-24 14:47:53 EDT
In installing 6.1 I found that the .bashrc file ends with a
floating "fi", which causes a complaint when logging in and
when a new terminal is brought up in GNOME.

The .bashrc file tries to execute "/etc/bashrc" but this
can't happen because the permissions on /etc/bashrc are all
set to "no execute".
Comment 1 Bill Nottingham 1999-10-25 11:30:59 EDT
Which bashrc are you talking about?

/etc/bashrc has:

# /etc/bashrc

# System wide functions and aliases
# Environment stuff goes in /etc/profile

# For some unknown reason bash refuses to inherit
# PS1 in some circumstances that I can't figure out.
# Putting PS1 here ensures that it gets loaded every time.
PS1="[\u@\h \W]\\$ "

and /etc/skel/.bashrc has:

# .bashrc

# User specific aliases and functions

# Source global definitions
if [ -f /etc/bashrc ]; then
	. /etc/bashrc
fi

I don't see any unbalanced ifs here, and sourcing /etc/bashrc
works fine.
Comment 2 Bill Nottingham 1999-10-26 11:38:59 EDT
The permissions on /etc/bashrc are 644;
with those permissions, the exact same snippet of
shell code works fine; i.e.  '. /etc/bashrc'.

Also, I tried adding a user with 'adduser foo', and
it came up with a normal (no extra fi) .bashrc.

Are you using something else to create the users?

Are you sure it's not something else giving you the error?
Comment 3 Cristian Gafton 2000-02-04 12:25:59 EST
Closed due to lack of feedback

Note You need to log in before you can comment on or make changes to this bug.