Bug 63115 - gaim default URL handler broken, fix attached
gaim default URL handler broken, fix attached
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gaim (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks: 61901 67218
  Show dependency treegraph
 
Reported: 2002-04-10 04:30 EDT by Warren Togami
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 00:11:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gaimrc.c patch to gaim-0.53-1.src.rpm (391 bytes, patch)
2002-04-10 04:31 EDT, Warren Togami
no flags Details | Diff
patch to gaim.spec (846 bytes, patch)
2002-04-10 04:35 EDT, Warren Togami
no flags Details | Diff
gaimrc.c patch against gaim-0.53-1.src.rpm (498 bytes, patch)
2002-04-13 04:43 EDT, Warren Togami
no flags Details | Diff
gaim.spec patch against gaim-0.53-1 (895 bytes, patch)
2002-04-13 04:44 EDT, Warren Togami
no flags Details | Diff
gaim-urlhandler.patch against gaim-0.59-6 rawhide (459 bytes, patch)
2002-08-05 08:50 EDT, Warren Togami
no flags Details | Diff
gaim-spec.patch against gaim-0.59-6 rawhide (1.08 KB, patch)
2002-08-05 08:51 EDT, Warren Togami
no flags Details | Diff

  None (edit)
Description Warren Togami 2002-04-10 04:30:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020405

Description of problem:
When you click on URL's in any gaim chat window, it sometimes opens Netscape
4.7x with the Red Hat welcome page, and sometimes it does nothing at all. 
Something about Netscape handling broke in Skipjack.

After you manually change the default Netscape to other browsers it works fine.
 I propose that the default gaim browser should be set to "GNOME URL Handler"
because Red Hat gaim depends on the existence of gnome, and the gnome setting
should always work by default.  The gnome default is Mozilla.

gaimrc.c and gaim.spec patch included below.

Version-Release number of selected component (if applicable):
Skipjack beta 2

How reproducible:
Always

Steps to Reproduce:
1. Run gaim with default settings.
2. Click on a URL in a chat window.

Actual Results:
Netscape doesn't bring you to that URL.  Sometimes it doesn't open Netscape at all.

Expected Results:
It should run the default browser and load the URL that you just clicked.

My proposed workaround fix that uses "GNOME URL Handler" by default is attached.
Comment 1 Warren Togami 2002-04-10 04:31:54 EDT
Created attachment 53044 [details]
gaimrc.c patch to gaim-0.53-1.src.rpm
Comment 2 Warren Togami 2002-04-10 04:35:39 EDT
Created attachment 53046 [details]
patch to gaim.spec
Comment 3 Bernhard Rosenkraenzer 2002-04-11 09:50:13 EDT
Better yet, make it use htmlview to catch a browser even if mozilla isn't installed.
Comment 4 Warren Togami 2002-04-13 04:43:37 EDT
Created attachment 53725 [details]
gaimrc.c patch against gaim-0.53-1.src.rpm
Comment 5 Warren Togami 2002-04-13 04:44:45 EDT
Created attachment 53726 [details]
gaim.spec patch against gaim-0.53-1
Comment 6 Warren Togami 2002-04-13 04:45:53 EDT
Is this satisfactory?  Seems to work well.
Comment 7 Warren Togami 2002-05-09 04:15:39 EDT
Re-tested: Default (Netscape) URL handler still broken in Red Hat 7.3.

Please apply patch to change default URL handler to htmlview in order to fix this.
Comment 8 Warren Togami 2002-05-22 06:34:20 EDT
It would be very nice if the htmlview patch could be applied, perhaps along with
fixes for Bug 65263.
Comment 9 Matt Selsky 2002-05-22 12:13:05 EDT
Does htmlview need to be added to the "Requires" section of the spec file as a
dependency?
Comment 10 Warren Togami 2002-07-10 08:08:13 EDT
gaim has been upgraded to 0.59 in Limbo beta, this is good.

However, the default URL handler is still "Netscape".  This makes URL handling
even more broken by default, now that Netscape is no longer distributed.  Please
make the following to changes to the Limbo gaim package.

1. Make the default URL handler Manual, with "htmlview "%s" as the command. 
Bero suggested the use of htmlview during the Skipjack beta after I suggested
changing the default to "Mozilla".  htmlview seems more correct because it will
run any browser is available instead of making assumptions.
2. Add htmlview to the requires section of the gaim spec.
Comment 11 Warren Togami 2002-08-05 08:50:00 EDT
Created attachment 68884 [details]
gaim-urlhandler.patch against gaim-0.59-6 rawhide
Comment 12 Warren Togami 2002-08-05 08:51:34 EDT
Created attachment 68885 [details]
gaim-spec.patch against gaim-0.59-6 rawhide
Comment 13 Warren Togami 2002-08-05 08:52:38 EDT
I have tested a gaim package built with the above default URL handler change and
spec patch.  It now works properly with default settings.  Please apply.
Comment 14 Warren Togami 2002-08-11 17:52:15 EDT
gaim-0.59-7 added htmlview to requires, but is missing the above patch that uses
htmlview as the manual URL handler rather than Netscape.
Comment 15 Christopher Blizzard 2002-08-12 00:11:48 EDT
Woops.  Fixed in -8.

Note You need to log in before you can comment on or make changes to this bug.