Bug 631172 - [abrt] fontforge-20090923-3.fc13: SFIsSomethingBuildable: Process /usr/bin/fontforge was killed by signal 11 (SIGSEGV)
Summary: [abrt] fontforge-20090923-3.fc13: SFIsSomethingBuildable: Process /usr/bin/fo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fontforge
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:278851ffe463e26d5f0575f5d05...
: 640575 677014 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-07 17:08 UTC by arius
Modified: 2011-03-03 02:50 UTC (History)
5 users (show)

Fixed In Version: fontforge-20100501-7.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-02 01:53:18 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (28.47 KB, text/plain)
2010-09-07 17:08 UTC, arius
no flags Details
/.FontForge/prefs file (2.60 KB, text/plain)
2010-09-10 23:37 UTC, arius
no flags Details
Font with glyphs outside BMP (1.87 KB, text/plain)
2011-02-21 21:55 UTC, Paul Flo Williams
no flags Details

Description arius 2010-09-07 17:08:47 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: fontforge /home/ian/MikmaqReserve.sfd
component: fontforge
crash_function: SFIsSomethingBuildable
executable: /usr/bin/fontforge
kernel: 2.6.34.6-47.fc13.x86_64
package: fontforge-20090923-3.fc13
rating: 4
reason: Process /usr/bin/fontforge was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1283877587
uid: 500

comment
-----
In this case the key pressed was the space bar; however, this crash happens when other keys are pressed (I've tried Enter, direction arrows, and some letters).
Using the mouse does not cause a similar crash.
This did not happen in Fedora 11, in which I regularly used the keyboard to edit glyphs in FontForge. But ever since the upgrade to Fedora 13, this problem has consistently appeared whenever any key is pressed.

How to reproduce
-----
1. Load a font with FontForge (no problem).
2. Double-click with mouse on one font glyph, to open editor window for that glyph (no problem).
3. Press any key on the keyboard while glyph editing window active (application automatically crashes).

Comment 1 arius 2010-09-07 17:08:49 UTC
Created an attachment (id=444329)
File: backtrace

Comment 2 Paul Flo Williams 2010-09-10 16:51:01 UTC
I am struggling to reproduce this, despite the full backtrace and your good explanation. I can't get this to go wrong with this version, the version based on 20100501 from fc14, or current upstream.

1. Had you selected any points on the current glyph before pressing another key on the keyboard, or selected a particular tool? I ask because, in the absence of any selected points, I don't know why you'd be pressing Enter or arrow keys. Pressing normal alphanumerics should have the effect of opening tabs for other glyphs in the current editor window, and that works as expected for me.

2. Does this happen only on one particular font, and is there anything odd about the coverage of that font?

3. It may help to reproduce the problem if you can supply your personal prefs for FontForge (~/.FontForge/prefs), which you may wish to censor by removing the "Recent" lines from the bottom.

4. If the problem appears to be with a particular font, perhaps you could supply that too, either here or to me privately.

Comment 3 arius 2010-09-10 23:37:29 UTC
Created attachment 446612 [details]
/.FontForge/prefs file

Comment 4 arius 2010-09-10 23:50:18 UTC
In answer to your queries:

1. In this particular instance, I had the pointer tool selected, but I don't
think I had any points selected. However, when seeing this crash, I usually do
have one or more points selected, and the crash happens then too (while trying
to move, cut, copy or paste points). So, the crash has happened both with and
without any point selections.

2. I just tested a number of fonts in order to answer this. It doesn't happen
in every font. The fonts I see the instability in - STD and TTF alike - appear
to all have glyphs in one of the Private Use planes. Whenever I tested a glyph
in Plane 15 (where I've been doing almost all of my glyph design), the crash
happened every time. Testing glyphs in the BMP and SMP didn't seem to cause any
problem, even in unassigned codepoints and blocks (though I haven't tested the
BMP's Private Use Area).

3. The ./FontForge/prefs file is posted as an attachment.

4. The problem doesn't appear to be with a particular font; however, just in
case it actually is a font problem, I'll send you (privately) the font I've
seen the bulk of the crashes with.

Thank you very much for all your help on this. It's much appreciated :-)

Comment 5 Paul Flo Williams 2010-09-11 10:22:41 UTC
This seems to be a straightforward access off the end of an array when some Unicode properties are checked for the current glyph if you are using characters in Plane 16, Supplementary Private Use Area B.

I've just reported this upstream, as it occurs in latest CVS too.

Looking through recent messages here, I can see that Pablo Rodriguez
reported a crash at the same point to fontforge-users on 2010-08-17. He
was using Asana Math, which can be downloaded here:

http://mirror.ctan.org/fonts/Asana-Math/Asana-Math.otf

In his case, the problem can be seen in the main window by setting Compact
encoding and scrolling down, but you can also edit one of the alternates
from the PUA and pressing any alphanumeric or try to open the Element
menu.

[Two minutes later...]

Actually, I think I know what the right thing to do is here, so I'm submitting patch upstream.

Comment 6 Karel Klíč 2010-11-08 19:09:15 UTC
*** Bug 640575 has been marked as a duplicate of this bug. ***

Comment 7 Kevin Fenzi 2010-11-21 20:34:10 UTC
Did this fix land in 20100501? or is it only still in CVS?

Comment 8 Paul Flo Williams 2010-11-24 08:14:58 UTC
(In reply to comment #7)
> Did this fix land in 20100501? or is it only still in CVS?

I supplied the patch in September, so it didn't land in the May build :-P

Specifically, it is a single line change to fvcomposit.c, which was applied in revision 1.67.

http://fontforge.cvs.sourceforge.net/viewvc/fontforge/fontforge/fontforge/fvcomposit.c?r1=1.66&r2=1.67&view=patch

The same patch applies to F13 (20090923) and F14 (20100501).

Comment 9 Kevin Fenzi 2010-11-24 23:19:41 UTC
ok. Should I backport this to f13/f14? Or is a fix in rawhide good enough?

Arius?

Comment 10 Paul Flo Williams 2011-02-14 08:24:24 UTC
*** Bug 677014 has been marked as a duplicate of this bug. ***

Comment 11 Paul Flo Williams 2011-02-14 08:27:25 UTC
Kevin, may I suggest applying the patch from comment 8 to F14, as it has now occurred there as well?

Comment 12 Fedora Update System 2011-02-17 16:19:03 UTC
fontforge-20100501-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fontforge-20100501-7.fc15

Comment 13 Fedora Update System 2011-02-17 22:24:14 UTC
fontforge-20100501-7.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fontforge'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/fontforge-20100501-7.fc15

Comment 14 Fedora Update System 2011-02-19 19:45:30 UTC
fontforge-20100501-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fontforge-20100501-6.fc14

Comment 15 Fedora Update System 2011-02-21 21:28:01 UTC
fontforge-20100501-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fontforge-20100501-7.fc14

Comment 16 Paul Flo Williams 2011-02-21 21:55:40 UTC
Created attachment 480000 [details]
Font with glyphs outside BMP

Better late than never, here is a font that provokes the crash and proves the fix.
To reproduce, simply load FontForge with this font. You'll see a compact view of the glyphs, just three of them. Pressing Page Down will highlight the last one of the three, and pressing it again will crash FontForge.

You can get the same crash by uncompacting the glyph view (Encoding -> Compact) and using your mouse to scroll through the glyphs, though it'll take you longer to do.

Comment 17 cyrushmh 2011-02-22 08:57:39 UTC
thank you,all
I use f14 now,,

Comment 18 Fedora Update System 2011-03-02 01:53:07 UTC
fontforge-20100501-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2011-03-03 02:50:12 UTC
fontforge-20100501-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.