Bug 631197 - FTBFS zsh-4.3.10-5.fc14
FTBFS zsh-4.3.10-5.fc14
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: zsh (Show other bugs)
14
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F14FTBFS
  Show dependency treegraph
 
Reported: 2010-09-07 13:18 EDT by FTBFS
Modified: 2015-07-16 08:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, build scriptlets using the pipe character ("|") in some cases failed. This update properly sets the default handling of the SIGPIPE signal in build scriptlets, thus fixing the bug.
Story Points: ---
Clone Of:
: 993868 (view as bug list)
Environment:
Last Closed: 2010-12-07 12:41:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (229.67 KB, text/plain)
2010-09-07 13:18 EDT, FTBFS
no flags Details
build.log (174.43 KB, text/plain)
2010-09-07 13:18 EDT, FTBFS
no flags Details
mock.log (886 bytes, text/plain)
2010-09-07 13:18 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-09-07 13:18:30 EDT
zsh-4.3.10-5.fc14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-09-07 13:18:33 EDT
Created an attachment (id=444450)
root.log

root.log for x86_64
Comment 2 FTBFS 2010-09-07 13:18:35 EDT
Created an attachment (id=444451)
build.log

build.log for x86_64
Comment 3 FTBFS 2010-09-07 13:18:37 EDT
Created an attachment (id=444452)
mock.log

mock.log for x86_64
Comment 4 James Antill 2010-12-06 11:04:10 EST
 This is the failure, in make check:

Running test: SH_NULLCMD option
*** /tmp/zsh.ztst.err.26567	Sun Sep  5 09:13:53 2010
--- /tmp/zsh.ztst.terr.26567	Sun Sep  5 09:13:53 2010
***************
*** 0 ****
--- 1,2 ----
+ fn:echo:2: write error: broken pipe
+ fn:2: write error: inappropriate ioctl for device
Test ./E01options.ztst failed: error output differs from expected as shown above for:
  print this is bar >bar
  fn() {
    local NULLCMD=cat READNULLCMD=cat
    echo hello | >foo
    cat foo
    <bar
  }
  setopt shnullcmd
  print option set
  fn
  unsetopt shnullcmd
  print option unset
  fn
  rm -f foo bar
Was testing: SH_NULLCMD option
./E01options.ztst: test failed.
Comment 5 Toshio Kuratomi 2010-12-07 12:41:34 EST
Rebuilt for F15.  note that I didn't change anything in the zsh spec file that would fix this issue so it seems that the source of the problem is in a dependent package (or the error is transient and we'll see it again).

http://koji.fedoraproject.org/koji/taskinfo?taskID=2649558
Comment 6 Adrian Reber 2011-01-18 17:15:33 EST
Same test failed on ppc:

http://ppc.koji.fedoraproject.org/koji/getfile?taskID=119526&name=build.log
Comment 7 Dan Horák 2011-02-02 08:51:07 EST
and also on s390x - http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=298864

Note You need to log in before you can comment on or make changes to this bug.