Bug 63120 - Broken options in logwatch-2.6-1 config files
Summary: Broken options in logwatch-2.6-1 config files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logwatch (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-10 09:05 UTC by Bernd Bartmann
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 09:06:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernd Bartmann 2002-04-10 09:05:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:0.9.4)
Gecko/20011128 Netscape6/6.2.1

Description of problem:
In some logwatch config files under /etc/log.d/conf/services there are config
options like:
*OnlyService = sendmail
*RemoveHeaders
The problem is the star in front of the options. It should be replaced by a $
sign or perl can't directly handle these options as variables.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run logwatch and watch the output for sendmail -> all log header informations
are missing (like date and time)
2. change the config option "*RemoveHeaders =" to "*RemoveHeaders = no" in
/etc/log.d/conf/services/sendmail.conf
3. run logwatch again -> the log headers are still missing
4. now change the config option to "$RemoveHeaders = no"
5. run logwatch again -> everything is ok now	

Additional info:

Comment 1 Elliot Lee 2002-04-15 17:55:42 UTC
I put a patch in logwatch-2.6-2

Comment 2 Elliot Lee 2002-04-15 18:07:01 UTC
A little more clarification:

It appears as if the *FooBlah syntax is intended to run some scripts, and
everything except the first token (the script name) is ignored. The reason
changing the * to the $ worked is because it set a variable or something instead
of running the script. The right fix is to just remove the line altogether if
you don't want removeheaders run.


Note You need to log in before you can comment on or make changes to this bug.