Bug 631291 - RFE: yum downgrade can install i686 libs instead of downgrading the x86_64 ones
RFE: yum downgrade can install i686 libs instead of downgrading the x86_64 ones
Status: CLOSED DUPLICATE of bug 549404
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-07 14:17 EDT by Till Maas
Modified: 2014-01-21 18:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-14 12:47:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2010-09-07 14:17:26 EDT
Description of problem:
If I run yum downgrade cups, yum installs i686 libs instead of the x86_64 ones.

Version-Release number of selected component (if applicable):
yum-3.2.28-3.fc12

How reproducible:
I believe to have seen this in some other case, too.

Steps to Reproduce:
1. yum update cups --enablerepo updates-testing
2. yum downgrade cups


Actual results:
  --> Führe Transaktionsprüfung aus
---> Paket cups.x86_64 1:1.4.1-13.fc12 markiert, um downgraded zu werden
--> Verarbeite Abhängigkeiten: cups-libs = 1:1.4.1-13.fc12 für Paket: 1:cups-1.4.1-13.fc12.x86_64
---> Paket cups.x86_64 1:1.4.4-5.fc12 markiert, um gelöscht zu werden
--> Führe Transaktionsprüfung aus
---> Paket cups-libs.i686 1:1.4.1-13.fc12 markiert, um installiert zu werden
--> Verarbeite Abhängigkeiten: libavahi-common.so.3 für Paket: 1:cups-libs-1.4.1-13.fc12.i686
--> Verarbeite Abhängigkeiten: libavahi-client.so.3 für Paket: 1:cups-libs-1.4.1-13.fc12.i686
--> Verarbeite Abhängigkeiten: libaudit.so.1 für Paket: 1:cups-libs-1.4.1-13.fc12.i686
--> Verarbeite Abhängigkeiten: libtiff.so.3 für Paket: 1:cups-libs-1.4.1-13.fc12.i686
--> Führe Transaktionsprüfung aus
---> Paket audit-libs.i686 0:2.0.4-1.fc12 markiert, um installiert zu werden
---> Paket avahi.i686 0:0.6.25-7.fc12 markiert, um installiert zu werden
--> Verarbeite Abhängigkeiten: libcap.so.2 für Paket: avahi-0.6.25-7.fc12.i686
--> Verarbeite Abhängigkeiten: libdaemon.so.0 für Paket: avahi-0.6.25-7.fc12.i686
---> Paket libtiff.i686 0:3.9.4-1.fc12 markiert, um installiert zu werden
--> Führe Transaktionsprüfung aus
---> Paket libcap.i686 0:2.16-5.fc12 markiert, um installiert zu werden
--> Verarbeite Abhängigkeiten: libattr.so.1(ATTR_1.0) für Paket: libcap-2.16-5.fc12.i686
--> Verarbeite Abhängigkeiten: libattr.so.1 für Paket: libcap-2.16-5.fc12.i686
---> Paket libdaemon.i686 0:0.14-1.fc12 markiert, um installiert zu werden
--> Führe Transaktionsprüfung aus
---> Paket libattr.i686 0:2.4.44-1.fc12 markiert, um installiert zu werden
--> Abhängigkeitsauflösung beendet

=============================================================================================================================================================
 Paket                                 Arch                              Version                                    Repository                         Grösse
=============================================================================================================================================================
Downgrading:
 cups                                  x86_64                            1:1.4.1-13.fc12                            fedora                             2.3 M
Installiert für Abhängigkeiten:
 audit-libs                            i686                              2.0.4-1.fc12                               updates                             61 k
 avahi                                 i686                              0.6.25-7.fc12                              updates                            250 k
 cups-libs                             i686                              1:1.4.1-13.fc12                            fedora                             316 k
 libattr                               i686                              2.4.44-1.fc12                              updates                             14 k
 libcap                                i686                              2.16-5.fc12                                fedora                              29 k
 libdaemon                             i686                              0.14-1.fc12                                fedora                              27 k
 libtiff                               i686                              3.9.4-1.fc12                               updates                            337 k

Vorgangsübersicht
=============================================================================================================================================================
Install       7 Package(s)
Downgrade     1 Package(s)



Expected results:
yum should probably downgrade some lib to a x86_64 version.

Additional info:
Comment 1 James Antill 2010-09-07 14:57:03 EDT
This is a known "feature" atm. Use "yum downgrade cups cups-libs" or "yum history undo", which will do both (and any others) for you.

Eventually we might change the depsolver to understand downgrade deps. ... and we might do the same thing we do now for downgrade remove (ie. just fail the downgrade instead of installing the .i?86 versions too). Both of those will take time though (the later much less than the former).
Comment 2 James Antill 2010-09-14 12:47:33 EDT

*** This bug has been marked as a duplicate of bug 549404 ***

Note You need to log in before you can comment on or make changes to this bug.