Bug 63135 - Ukrainian fonts are bigger than fonts for other locales
Ukrainian fonts are bigger than fonts for other locales
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gtk+ (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-04-10 10:25 EDT by Leonid Kanter
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 12:14:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this patch fixes font size and also font foundry in gtkrc.ru (1.33 KB, patch)
2002-04-10 10:32 EDT, Leonid Kanter
no flags Details | Diff

  None (edit)
Description Leonid Kanter 2002-04-10 10:25:51 EDT
Description of Problem:

If you start gtkrc application in uk_UA locale, fonts are bigger than if
application is started in en_US or ru_RU.koi8r locale.

Version-Release number of selected component (if applicable):

1.2.10-11

How Reproducible:

always

Steps to Reproduce:
1. install beta4 with Russian and Ukrainian languages enabled
2. start the same gtk application in C, ru_RU.koi8r and uk_UA locales


Actual Results:

you'll see than in application started in Ukrainian locale fonts are bigger

Expected Results:

Font size must be the same for all locales

Additional Information:
	
It happens because there are 14 points fonts in gtkrc.uk while all other gtkrc
files are configured for 12 points.
Comment 1 Leonid Kanter 2002-04-10 10:32:30 EDT
Created attachment 53104 [details]
this patch fixes font size and also font foundry in gtkrc.ru
Comment 2 Owen Taylor 2002-04-10 19:28:04 EDT
Why does your patch change the foundary for Russian from cronyx to *?
The fonts we ship have cronyx as the foundary; are there other fonts
out there that people use that have different foundaries? If * is
in the foundary field, it won't be deterministic which one gets
chosen. (I think actually cronyx will typically be chosen because
it is early in the alphabet)
Comment 3 Owen Taylor 2002-04-11 12:08:29 EDT
Fixed in 1.2.10-12
Comment 4 Leonid Kanter 2002-04-11 12:14:08 EDT
cyrillic fonts from fonts-KOI8-R package (which are preferred for koi8-r
encoding) have "adobe" foundry. "cronyx" fonts from XFree86-cyrillic package are
broken, see  bug 59484 for example. 
Comment 5 Owen Taylor 2002-04-11 12:17:20 EDT
OK, so this doesn't actually matter... the -adobe-.....-iso8859-1 
pattern actually will pick up the koi8-u font since character
sets are ignored in fontset patterns-- it's as if all the patterns
end in -*-*. (Yes, this is confusing.)

Anyways, the change is in the current package, whenever that propagates
to Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.