Bug 631404 - FTBFS qucs-0.0.15-4.fc12
FTBFS qucs-0.0.15-4.fc12
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qucs (Show other bugs)
14
All Linux
high Severity high
: ---
: ---
Assigned To: Eric Tanguy
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
: 716131 (view as bug list)
Depends On:
Blocks: F14FTBFS
  Show dependency treegraph
 
Reported: 2010-09-07 14:44 EDT by FTBFS
Modified: 2011-07-09 06:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-09 06:51:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (286.78 KB, text/plain)
2010-09-07 14:44 EDT, FTBFS
no flags Details
build.log (213.07 KB, text/plain)
2010-09-07 14:44 EDT, FTBFS
no flags Details
mock.log (882 bytes, text/plain)
2010-09-07 14:44 EDT, FTBFS
no flags Details
root.log (446.39 KB, text/plain)
2010-09-07 14:44 EDT, FTBFS
no flags Details
build.log (196.93 KB, text/plain)
2010-09-07 14:44 EDT, FTBFS
no flags Details
mock.log (890 bytes, text/plain)
2010-09-07 14:44 EDT, FTBFS
no flags Details
Commit to update to 0.0.16 (1.20 KB, message/rfc822)
2011-07-03 09:40 EDT, Bruno Wolff III
no flags Details
Commit to prevent use of tr1 for complex functions. (1.89 KB, message/rfc822)
2011-07-03 09:42 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description FTBFS 2010-09-07 14:44:06 EDT
qucs-0.0.15-4.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-09-07 14:44:09 EDT
Created an attachment (id=445418)
root.log

root.log for i386
Comment 2 FTBFS 2010-09-07 14:44:11 EDT
Created an attachment (id=445419)
build.log

build.log for i386
Comment 3 FTBFS 2010-09-07 14:44:12 EDT
Created an attachment (id=445420)
mock.log

mock.log for i386
Comment 4 FTBFS 2010-09-07 14:44:13 EDT
Created an attachment (id=445421)
root.log

root.log for x86_64
Comment 5 FTBFS 2010-09-07 14:44:15 EDT
Created an attachment (id=445422)
build.log

build.log for x86_64
Comment 6 FTBFS 2010-09-07 14:44:16 EDT
Created an attachment (id=445423)
mock.log

mock.log for x86_64
Comment 7 Eric Tanguy 2011-06-25 02:39:25 EDT
*** Bug 716131 has been marked as a duplicate of this bug. ***
Comment 8 Eric Tanguy 2011-06-27 02:59:16 EDT
A new version is out and i'm trying to build and package it.
Comment 9 Bruno Wolff III 2011-07-02 15:11:03 EDT
0.0.16 has been available since March, but seems to have the same issue building as 0.0.15.
Comment 10 Bruno Wolff III 2011-07-02 16:02:58 EDT
It looks like there is an issue when trying to use the TR1 complex functions. I think the best short term fix is to just use the normal complex functions instead. The problem should probably be reported upstream to get a real fix in the code in a future release.
I am doing a new local build now. If that finishes (i.e. there aren't other problems), I'll post a diff you can apply that both goes to 0.0.16 and fixes the build issue. I have already uploaded qucs-0.0.16.tar.gz to the lookaside cache.
Comment 11 Bruno Wolff III 2011-07-02 17:29:48 EDT
Just undefining HAVE_TR1_COMPLEX doesn't seem to solve the problem. spfile builds, but other stuff doesn't.
Rebuilding configure from configure.ac doesn't work as some related macros don't appear to be defined.
Comment 12 Bruno Wolff III 2011-07-02 23:40:35 EDT
It looks like adding the name space to conj references will fix things. I am tracking down other files that need this. This will be a hack, since the changes assume that std::tr1 is being used for complex functions. This should be OK for Fedora, but upstream will want to do something more complex so things work on systems that don't have tr1.
Comment 13 Bruno Wolff III 2011-07-03 08:54:05 EDT
It turns out that after starting to use explicit naming, other issues showed up. I am now trying to make the configure test for tr1 fail. A short test, suggested this will work, but the full build is still running.
Comment 14 Bruno Wolff III 2011-07-03 09:40:19 EDT
Created attachment 511053 [details]
Commit to update to 0.0.16
Comment 15 Bruno Wolff III 2011-07-03 09:42:44 EDT
Created attachment 511054 [details]
Commit to prevent use of tr1 for complex functions.

I tested this with a local build and the package built.
I didn't do it in a mock environment, so I wouldn't have noticed at least some changes in build requirements. I didn't try running the package to make sure it functions properly.

Note You need to log in before you can comment on or make changes to this bug.