This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 631480 - broken NSS dependencies prevent Fedora 14 curl from being built
broken NSS dependencies prevent Fedora 14 curl from being built
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
14
All Linux
high Severity high
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F14FTBFS 631449
  Show dependency treegraph
 
Reported: 2010-09-07 15:19 EDT by Kamil Dudka
Modified: 2010-09-07 16:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 631449
Environment:
Last Closed: 2010-09-07 16:53:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Dudka 2010-09-07 15:19:52 EDT
+++ This bug was initially created as a clone of Bug #631449 +++

curl-7.21.0-4.fc14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

--- Additional comment from ftbfs@fedoraproject.org on 2010-09-07 20:56:53 CEST ---

Created an attachment (id=445656)
root.log

root.log for x86_64

--- Additional comment from ftbfs@fedoraproject.org on 2010-09-07 20:56:55 CEST ---

Created an attachment (id=445657)
build.log

build.log for x86_64

--- Additional comment from ftbfs@fedoraproject.org on 2010-09-07 20:56:56 CEST ---

Created an attachment (id=445658)
mock.log

mock.log for x86_64

--- Additional comment from kdudka@redhat.com on 2010-09-07 21:16:13 CEST ---

This is bug 626470, will check why our workaround is not working here...
Comment 1 Kamil Dudka 2010-09-07 15:20:48 EDT
http://koji.fedoraproject.org/koji/getfile?taskID=2452627&name=root.log

...

DEBUG backend.py:605:  /usr/bin/yum --installroot /var/lib/mock/dist-f14-build-879686-128933/root/  groupinstall srpm-build
DEBUG util.py:289:  Executing command: /usr/bin/yum --installroot /var/lib/mock/dist-f14-build-879686-128933/root/  groupinstall srpm-build
DEBUG util.py:255:  Error: Package: nss-3.12.7-4.fc14.x86_64 (build)
DEBUG util.py:255:             Requires: nss-util >= 3.12.7
DEBUG util.py:255:             Installing: nss-util-3.12.6-1.fc14.x86_64 (build)
DEBUG util.py:255:                 nss-util = 3.12.6-1.fc14
DEBUG util.py:255:   You could try using --skip-broken to work around the problem
DEBUG util.py:255:  Error: Package: nss-3.12.7-4.fc14.x86_64 (build)
DEBUG util.py:255:             Requires: nss-softokn(x86-64) >= 3.12.7
DEBUG util.py:255:             Available: nss-softokn-3.12.6-3.fc14.x86_64 (build)
DEBUG util.py:255:                 nss-softokn(x86-64) = 3.12.6-3.fc14
DEBUG util.py:255:   You could try running: rpm -Va --nofiles --nodigest
DEBUG util.py:328:  Child returncode was: 1

...
Comment 2 Mamoru TASAKA 2010-09-07 16:27:42 EDT
Currently tracked on:
https://fedorahosted.org/rel-eng/ticket/4080
Comment 3 Kai Engert (:kaie) 2010-09-07 16:35:16 EDT
/me wonders why such bugs are still being assigned to me by default
Comment 4 Kamil Dudka 2010-09-07 16:53:22 EDT
The build of curl-7.21.0-5.fc14 seems to be in progress now, I am closing the bug...

Note You need to log in before you can comment on or make changes to this bug.