Bug 631579 - hdparm not reporting the correct output on virtio drives
hdparm not reporting the correct output on virtio drives
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: chellwig@redhat.com
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2010-09-07 18:39 EDT by Pranesh Medilall
Modified: 2011-01-14 12:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-14 12:04:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport from server (2.96 MB, application/x-bzip2)
2010-09-07 18:39 EDT, Pranesh Medilall
no flags Details

  None (edit)
Description Pranesh Medilall 2010-09-07 18:39:06 EDT
Created attachment 445797 [details]
sosreport from server

Description of problem:

When running hdparm against a virtio device the following error is thrown out :

# hdparm -t /dev/vda

/dev/vda:
Timing buffered disk reads:  104 MB in  3.02 seconds =  34.48 MB/sec
HDIO_DRIVE_CMD(null) (wait for flush complete) failed: Inappropriate ioctl for device 

Version-Release number of selected component (if applicable):

kvm-83-105.el5.X86_64
hdparm-6.6-2.X86_64


How reproducible:

Always


Steps to Reproduce:
1.Run the hdparm -t /dev/vda device
2.Run the hdparm -T /dev/vda device
3.
  
Actual results:

Timing buffered disk reads:  104 MB in  3.02 seconds =  34.48 MB/sec
HDIO_DRIVE_CMD(null) (wait for flush complete) failed: Inappropriate ioctl for device


Expected results:

[root@dhcp-1-24 ~]# hdparm -t /dev/sda1

/dev/sda1:
 Timing buffered disk reads:  100 MB in  1.20 seconds =  83.54 MB/sec
[root@dhcp-1-24 ~]# hdparm -T /dev/sda1

/dev/sda1:
 Timing cached reads:   13292 MB in  2.00 seconds = 6656.93 MB/sec
[root@dhcp-1-24 ~]# 


Additional info:
Comment 1 RHEL Product and Program Management 2011-01-11 15:27:16 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2011-01-11 17:52:56 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 3 chellwig@redhat.com 2011-01-14 12:04:24 EST
hdparm is for ATA disks.  And it also pretty clearly said that it got the correct error back.  The only bug is the user running hdparm against devices it doesn't support.

Note You need to log in before you can comment on or make changes to this bug.