Bug 63160 - RFE: reject packages depending on GLIBC_PRIVATE
RFE: reject packages depending on GLIBC_PRIVATE
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-10 14:56 EDT by Ulrich Drepper
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 14:38:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2002-04-10 14:56:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020408

Description of problem:
glibc 2.3 (and the one in the next RH release) will feature a special version
name GLIBC_PRIVATE which is used to mark all internal interfaces.  No program
outside glibc must use them.  The linker will create such binaries, we cannot
prevent it.  But we can now easily detect such binaries and rpm is in the
position to reject packaging them.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. echo 'int main (void) { return __libc_write (1, "hello\n", 6); }' > foo.c
2. gcc foo.c
3. ldd a.out
	

Expected Results:  The ldd output should show a reference to GLIBC_PRIVATE. 
Packaging such a file should fail.

Additional info:
Comment 1 Jeff Johnson 2003-09-29 14:38:59 EDT
Rejecting packages based on GLIBC_PRIVATE is beyond the
scope of rpm. Meanwhile, a reasonable filtering scheme
for GLIBC_PRIVATE has been added to rpm-4.2.1-4.2, filtering
all Provides: yadda(GLIBC_PRIVATE) except when explicitly
overridden in the glibc build. That should have nearly the
same effect of "rejecting packages" because of failed dependencies.
Comment 2 Aleksey Nogin 2004-01-03 21:51:18 EST
This issue seems to be back - see bug 112849

Note You need to log in before you can comment on or make changes to this bug.