Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
When paused button in KVM is pressed, RHEL6 guest is suspended.
But even if paused button is pressed once again, the guest does not return, and is still suspended.
This problem is only solved by reboot host.
Guest is still suspended if "shutdown" or "force off" on KVM is selected after this problem occurred.
And guest is still suspended if KVM and libvirtd service are restarted.
When guest OS is RHEL4.8 or RHEL5.5, this problem does not occur.
When paused button is pressed after KVM is minimized(actually closed) and opens once again,
the dialog box holds, and the following message is output in the dialog box.
-----
Error unpausing domain: Timed out during
operation: cannot acquire state change lock
* detail
Traceback (most recent call last)
File "/usr/share/virt-manager/virtManager/engine.py",
line 867, in resume_domain
vm.resume()
File "/usr/share/virt-manager/virtManager/domain.py",
line 1328, in resume
self._backend.resume()
File "/usr/lib64/python2.6/site-packages/libvirt.py".line
592, in resume
if ret == -1: raise libvirtError ('virDomainResume()
failed', dom=self)
libvirtError: Timed out during operation: cannot acquire
state change lock
-----
How reproducible:
always
Steps to Reproduce:
- Host
1. Install RHEL6
2. Boot RHEL6
3. Start to Virtual Machine Manager, and add to guest
4. Install RHEL6 as guest OS
- Guest
1. Boot RHEL6
2. Press paused button on KVM
Version-Release number of selected component (if applicable):
Host : RHEL6 Snapshot 12 x86_64
kernel version: 2.6.32-66.el6.x86_64
qemu-kvm-0.12.1.2-2.112.el6.x86_64
libvirt-0.8.1-27.el6.x86_64
Guest: RHEL6 Snapshot 12 x86_64
kernel version: 2.6.32-66.el6.x86_64
How reproducible:
100%
Steps to Reproduce:
- Host
1. Install RHEL6
2. Boot RHEL6
3. Start to Virtual Machine Manager, and add to guest
4. Install RHEL6 as guest OS
- Guest
1. Boot RHEL6
2. Press paused button on KVM
Actual results:
RHEL6 guest is stalled after suspended on KVM.
Expected results:
Guest can return after suspened.
Additional info:
I can reproduce this issue when the guest kernel is upgraded 2.6.32-66.el6.x86_64, but it works well with guest kernel 2.6.32-19.el6.x86_64.
And this issue only happened on pressing the "pause" button in virt-manager. I can successfully suspend and then resume the same VM via virsh.
After the VM is paused by virt-manager, try to use virsh to resume it:
[root@localhost ~]# virsh list
Id Name State
----------------------------------
2 rhel5.4 running
3 rhel6 paused
[root@localhost ~]# virsh resume rhel6
error: Failed to resume domain rhel6
error: Timed out during operation: cannot acquire state change lock
Description of problem: When paused button in KVM is pressed, RHEL6 guest is suspended. But even if paused button is pressed once again, the guest does not return, and is still suspended. This problem is only solved by reboot host. Guest is still suspended if "shutdown" or "force off" on KVM is selected after this problem occurred. And guest is still suspended if KVM and libvirtd service are restarted. When guest OS is RHEL4.8 or RHEL5.5, this problem does not occur. When paused button is pressed after KVM is minimized(actually closed) and opens once again, the dialog box holds, and the following message is output in the dialog box. ----- Error unpausing domain: Timed out during operation: cannot acquire state change lock * detail Traceback (most recent call last) File "/usr/share/virt-manager/virtManager/engine.py", line 867, in resume_domain vm.resume() File "/usr/share/virt-manager/virtManager/domain.py", line 1328, in resume self._backend.resume() File "/usr/lib64/python2.6/site-packages/libvirt.py".line 592, in resume if ret == -1: raise libvirtError ('virDomainResume() failed', dom=self) libvirtError: Timed out during operation: cannot acquire state change lock ----- How reproducible: always Steps to Reproduce: - Host 1. Install RHEL6 2. Boot RHEL6 3. Start to Virtual Machine Manager, and add to guest 4. Install RHEL6 as guest OS - Guest 1. Boot RHEL6 2. Press paused button on KVM Version-Release number of selected component (if applicable): Host : RHEL6 Snapshot 12 x86_64 kernel version: 2.6.32-66.el6.x86_64 qemu-kvm-0.12.1.2-2.112.el6.x86_64 libvirt-0.8.1-27.el6.x86_64 Guest: RHEL6 Snapshot 12 x86_64 kernel version: 2.6.32-66.el6.x86_64 How reproducible: 100% Steps to Reproduce: - Host 1. Install RHEL6 2. Boot RHEL6 3. Start to Virtual Machine Manager, and add to guest 4. Install RHEL6 as guest OS - Guest 1. Boot RHEL6 2. Press paused button on KVM Actual results: RHEL6 guest is stalled after suspended on KVM. Expected results: Guest can return after suspened. Additional info: