Bug 631659 - Xorg zoom keys (alt-ctrl-keypad-plus and minus) don't work
Summary: Xorg zoom keys (alt-ctrl-keypad-plus and minus) don't work
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-08 05:46 UTC by D. Hugh Redelmeier
Modified: 2018-04-11 11:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-28 13:13:45 UTC
Type: ---


Attachments (Terms of Use)
xorg log (43.10 KB, text/plain)
2010-09-08 05:46 UTC, D. Hugh Redelmeier
no flags Details

Description D. Hugh Redelmeier 2010-09-08 05:46:30 UTC
Created attachment 445854 [details]
xorg log

Description of problem:
The zoom keys (alt-ctrl-kp-plus and alt-ctrl-kp-minus) don't work.

Version-Release number of selected component (if applicable):
1.8.2-3

How reproducible:
always on my system (radeon driver).

Steps to Reproduce:
1. under X, type ctrl-alt-+, ctrl-alt--, ctrl-alt-keypad+, or ctrl-alt-keypad-

Actual results:
the display is unchanged

Expected results:
the display mode should change (cycle through active modelines)

Additional info:

Similar observations as in <https://bugzilla.redhat.com/show_bug.cgi?id=216656>

I created an /etc/X11/xorg.conf and added:
  Section "ServerFlags"
        Option "DontZoom" "false"
  EndSection

This didn't help.

I ran xev and found that the keystrokes seemed to generate the right keysyms.  For example:
    KeyRelease event, serial 33, synthetic NO, window 0x3800001,
        root 0xf9, subw 0x0, time 23521050, (1400,548), root:(1662,639),
        state 0x1c, keycode 86 (keysym 0x1008fe22, XF86_Next_VMode), same_screen YES,
        XLookupString gives 0 bytes: 
        XFilterEvent returns: False

dmesg shows nothing interesting.

Xorg.0.log isn't very interesting but I will include it.

xrandr can switch modes so this shows that more than one modeline is useable.

I posted this message to the fedora users list: <http://lists.fedoraproject.org/pipermail/users/2010-September/382361.html>

Comment 1 Matěj Cepl 2010-09-08 08:31:10 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, from reading of the referred email report, it seems that you actually don't want to use this thing as such (for zooming of the screen), but just as a way how to overcome some problems with your driver, right? I think that http://article.gmane.org/gmane.linux.redhat.fedora.general/378356 is right and zooming went way of Dodo with KMS being introduced (but I cannot find any evidence for this statement ATM, sorry).

Which leads to two more questions ... if you switch off KMS (by putting nomodeset on your kernel command line either in grub menu for one startup or in /etc/grub.conf permanently), does the functionality returns?

Also, do other Ctrl-Alt- key combinations work (especially Ctrl-Alt-F2 for switching to console? Wouldn't it help in your situation as well)?

For the resolution of your underlying issue, please add drm.debug=0x04 to the kernel command line, restart computer, and when the problem happens, dig out the following (you may need to switch to console and/or get into your computer via ssh) and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* a fresh copy of X server log file (/var/log/Xorg.*.log),
* output of xrandr --query --verbose,
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 D. Hugh Redelmeier 2010-09-10 06:14:20 UTC
MC: You are right that I have a more serious problem than this one.  Unfortunately, it isn't reproducible.  If I get more information, I will start another bugzilla entry.

Back to the zoom problem...

If zooming (odd term for cycling between active modes) is no longer, that ought to be documented.  If it is, that's the end of this bz: case solved.  But the feature is documented: see the description of Option "DontZoom" in xorg.conf(5).

I tried nomodeset and zooming still didn't happen.

Yes, CTRL-ALT-F2 etc. do work as they should, with or without "nomodeset".

When the screen has blanked in the problematic way, CTRL-ALT-F2 does not help.  To be honest, I have no idea that zoom would help (but sshing in from another machine and doing the xrandr commands to switch mode does work).

I noticed that when I look at the output of xev, and press CTRL-ALT-KP+, I get a keyrelease event with ksym XF86_Next_VMode (as shown above), but I don't get a keypress event for it.  I wonder where the keypress event is going?  I notice a similar behaviour if I type CTR-ALT-F1 (which switches VTs to the one that happens to be current).

I tried zoom on my notebook (64-bit Fedora 13 on Thinkpad x61t (intel video)).  Same non-behaviour.  So this isn't only a radeon problem.

Is that enough information to work on the zoom problem?

Comment 3 Bug Zapper 2011-05-31 14:09:51 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Bug Zapper 2011-06-28 13:13:45 UTC
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.