Bug 6317 - knfsd can't export across mountpoints, user-space nfsd not available
knfsd can't export across mountpoints, user-space nfsd not available
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: knfsd (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
: 6680 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-24 19:09 EDT by jered
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 10:40:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jered 1999-10-24 19:09:10 EDT
In RedHat 6.0, the user-space nfs server was replaced with
knfsd. knfsd will not export across local mount points. The
other mount points can be listed in /etc/exports, but they
must be individually mounted by the client machines.  This
is different behaviour than earlier releases, and is not
desireable.

As there seems to be no easy way to fix this, I want to use
the user-space NFS server. Even though the kernel-space NFS
is still considered experimental, RedHat has made it the
default and not even provided the user-space server as an
option! Bring back the user-space server as an optional
package until the kernel-space server has equivalent
functionality!
Comment 1 Jeff Johnson 1999-11-05 08:14:59 EST
*** Bug 6680 has been marked as a duplicate of this bug. ***

i have / exported to another computer. Everything works fine
, until I attempt to enter a directory which is mounted from
a seperate partition , say , /dos , instead of /sbin.

An empty directory is all that is brought up. I have Sun NFS
server compiled into my kernel. I can't see why it isn't
working. I'm running 2.2.13 , now. 2.2.12-20 didn't work
either. I suspect this might be a bug in knfsd?

------- Additional Comments From gbb@dcs.st-and.ac.uk  11/03/99 11:08 -------
apologies, this is a repeat of bug #6317, which I should have checked
for more carefully.
Comment 2 Alan Cox 2000-02-17 10:40:59 EST
This is how all normal NFS daemons work. They expect you to export
and mount each mount point you need. Without doing this you get
potential clashing file handles - a problem unfsd has in such
configurations that can cause bogus 'Stale NFS handle' and othr
such messages.

Note You need to log in before you can comment on or make changes to this bug.