Bug 631761 - [Pango][Cursoring][mr_IN] - Composed Character Deletion is wrong with DELETE Button
[Pango][Cursoring][mr_IN] - Composed Character Deletion is wrong with DELETE ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pango (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Akira TAGOH
Desktop QE
: i18n
Depends On: 635957 635961
Blocks: 631768
  Show dependency treegraph
 
Reported: 2010-09-08 06:39 EDT by Satyabrata Maitra
Modified: 2015-09-15 03:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 631768 (view as bug list)
Environment:
Last Closed: 2015-09-15 03:03:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2010-09-08 06:39:02 EDT
Description of problem:
In pango (tested it in gedit and firefox), the deletion with DELETE key, is not following the rule of deleting entire composed character with a single key press. It is deleting each of the character in a composed character, one by one.

Version-Release number of selected component (if applicable):
pango-1.28.1-3.el6.x86_64
pangomm-2.26.0-1.el6.x86_64
gedit-2.28.4-3.el6.x86_64
firefox-3.6.8-1.el6.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Open gedit or firefox in mr_IN locale
2. Activate ibus with CTRL+SPACE. Select marathi - Inscript
3. Type : kdk (which means consonant KA + Halant + Consonant KA)
4. Position the cursor at the beginning point of the composed character.
5. Now, press DELETE key. (It needs 3 key strokes to delete the whole character, but it should be done with a single key stroke in fact)

Actual results:
Delete composed character is happening in wrong manner. Actually it is now following the convention (Rule) of BACKSPACE, when deleting a composed character comes into picture.

Expected results:
It should delete the whole composed character in one DELETE key stroke when cursor positions at the start of the composed character.

Additional info:
Comment 1 Satyabrata Maitra 2010-09-08 06:40:36 EDT
OS : RHEL6-Workstation-Snapshot-13
Arch : x86_64
Comment 3 RHEL Product and Program Management 2011-01-07 10:47:41 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 6 Akira TAGOH 2014-01-27 22:08:40 EST
This seems not yet fixed in even f20. though the cursor stops in between. is it also wrong then?

Note You need to log in before you can comment on or make changes to this bug.