Bug 631796 - Install from NTFS partition does not work
Summary: Install from NTFS partition does not work
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 14
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-08 12:23 UTC by Hedayat Vatankhah
Modified: 2011-10-25 11:09 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-10-21 17:44:14 UTC


Attachments (Terms of Use)

Description Hedayat Vatankhah 2010-09-08 12:23:02 UTC
Description of problem:
I've tried installing Fedora 14 Alpha from hard disk. After selecting the hard disk partition and entering the path of the image, I press next. Then, the selection window disappears and nothing appears again. The blue screen remains on the screen and nothing happens. The last messages in other virtual screens say that the partition is successfully mounted and there is no error messages after wards. I've tried both with normal mode and using "nomodeset" options, the same thing happens. If I go to the second virtual screen (Alt+F2 or F3) and press Ctrl+Alt+Delete, the installer starts rebooting but then I see a dialoge in the blue screen (The first terminal) saying that the installer is unable to find appropriate installation image. But the DVD iso image and the images/install.img files are available in the path I enter.


How reproducible:
100%

Steps to Reproduce:
1. Boot Fedora 14 Alpha installer with a custom installation method
2. Select HardDisk installation mode
3. select the appropriate partition and enter the path containing Fedora 14 Alpha iso file and images directory containing install.img
4. press next
  
Actual results:
The dialoge disappears and nothing happens


Expected results:
It should either show an error dialog (which was shown if I reboot the system from another virtual terminal) or continue with the installation. In my case, I was sure that the selected partition and the entered path are OK, so it should continue with the installation. (I always install Fedora from hard disk on my system since it doesn't have any CD/DVD drive).

Comment 1 Brian Lane 2010-09-08 13:43:19 UTC
What, exactly, are the kernel commands you are booting with?

What is the path on your install partition and what does the directory look like? eg. ls -lR /path/to/install

Take a look at tty3 and tty5 for any errors.

Does tty2 have a shell? If so, could you go to /tmp/ and copy *log to another machine and attach them to this bug?

Comment 2 Hedayat Vatankhah 2010-09-13 09:59:23 UTC
I've booted kernel and initrd without any special arguments:
kernel /vmlinuz
initrd /initrd.img

This is the output of the ls command (The same problem with Fedora 14 Beta TC1):
[hedayat@localhost]AppInstall/Fedora% ls -lR .
.:
total 10202212
-rwxrwxrwx. 1 hedayat hedayat 3277086720 2010-05-26 06:17 Fedora-13-i386-DVD.iso
-rwxrwxrwx. 1 hedayat hedayat 3630045184 2010-05-25 22:33 Fedora-13-x86_64-DVD.iso
-rwxrwxrwx. 1 hedayat hedayat 3539900416 2010-09-13 04:06 Fedora-14-Beta-x86_64-DVD.iso
drwx------. 1 hedayat hedayat          0 2010-05-26 10:16 images
-rwxrwxrwx. 1 hedayat hedayat      27283 2010-05-25 21:37 jigdo-lite

./images:
total 153720
-rwxrwxrwx. 1 hedayat hedayat 157409280 2010-09-13 04:20 install.img


There is no errors in tty3 and tty5. The only error I see is when I reboot from tty3, which I see an error dialog in tty1 saying that it cannot find appropriate install image.

No, tty2 doesn't provide a shell yet.

Comment 3 Hedayat Vatankhah 2010-09-13 11:51:41 UTC
Apparently there is something wrong with handling NTFS file systems. If I select an ext3/4 partition and write a wrong path, an error dialog appears and says that it cannot find correct installation images. But when I select my NTFS partition, it doesn't show any dialogs before rebooting, and the entered path doesn't make any difference (same thing happens with the correct path and any arbitrary paths).

Comment 4 Brian Lane 2010-09-13 15:40:08 UTC
Can you try with the images on an ext4 partition?

Also, can you try with only the F14 iso in the directory.

Comment 5 Hedayat Vatankhah 2010-09-13 18:00:49 UTC
Using the same files in an ext4 partition works fine. There is certainly a problem with NTFS partitions. Whatever NTFS partition I select, regardless of the entered path, the installer just stops right after printing this message in tty3:

mounting device /dev/sdxx for hard disk installation

(And the message: "Path to stage2 images is ... " doesn't appear)

Having only F14 iso didn't help either (apparently, the installer does not reach that far at all. it simply stops when mounting or right after mounting an NTFS partition, without any error messages. (The tested partitions are clean and can be mounted and used under Linux without any problems)

Comment 6 Brian Lane 2010-09-15 21:36:52 UTC
NTFS isn't a supported as an install source. See http://docs.fedoraproject.org/en-US/Fedora/13/html/Installation_Guide/ch04s07.html

We should probably show an error though.

Comment 7 Hedayat Vatankhah 2010-09-17 11:22:40 UTC
BTW, it worked fine in F13 (and I think F12 too), so it is a regression in F14 anaconda and should be (hopefully) easy to fix.

Comment 8 Hedayat Vatankhah 2010-09-17 11:25:06 UTC
And I think the document is outdated, since before recent times in which I could install from NTFS successfully, anaconda showed an error when selecting NTFS partitions because it was unable to mount them at all in those times (apparently there were no NTFS support in the installer at all).

Comment 9 Hedayat Vatankhah 2010-10-11 11:00:07 UTC
Apparently (I heard from someone), the installer's problem with NTFS does not end here. It seems that if you have an NTFS partition in your current Fedora's /etc/fstab and you try to upgrade your Fedora to F14, it'll stop working too. I'm not sure but that might be the same problem.

Comment 10 Brian Lane 2010-10-21 17:44:14 UTC
Installing from NTFS is not a supported feature.

Comment 11 Hedayat Vatankhah 2010-10-21 18:29:08 UTC
OK, so maybe I should report a new bug as Feature Request, since on a modern hard drive (well, a Fedora featured harddrive!) it is not easy to find a FAT or a non-LVM ext partition (except the 500mb /boot partition); so hard disk install is very outdated and unusable in many modern hard disks!

Comment 12 Andre Robatino 2011-10-22 21:17:22 UTC
Has an RFE been filed for this issue?

Comment 13 Hedayat Vatankhah 2011-10-22 21:50:37 UTC
I intended to do so, but IIRC I didn't and I forgot to do it.

Comment 14 Andre Robatino 2011-10-22 22:01:32 UTC
In searching for existing bugs, I found bug 651534. In particular, https://bugzilla.redhat.com/show_bug.cgi?id=651534#c9 sounds like it wouldn't be possible anymore.

Comment 15 Hedayat Vatankhah 2011-10-22 22:38:40 UTC
No, it doesn't say that it is not possible to install from an NTFS partition anymore; it just says that there is no stage2 anymore where in Fedora 14 installer, anaconda hang when trying to mount stage2 from an NTFS partition. This is right, there is no stage2 so we don't have any problem here. However, we do want to mount Fedora iso from an NTFS partition, and now the installer hangs in this place (stage2 is now included in the initrd which is already completely loaded when installer reaches this step).

Therefore, we can open a new RFE and request for NTFS support. Apparently, the problem is still what stated there: the different behavior of mount for NTFS partitions. From what I read from that bug, it should be fairly easy to add the support back: either by putting a timeout when waiting for mount to terminate, or changing the mount.ntfs behavior (which seems to be harder or impossible). So, the timeout solution seems to be a good one. It can be used only when an NTFS partition is being mounted.

Comment 16 Hedayat Vatankhah 2011-10-25 11:09:30 UTC
RFE filled: bug #748780


Note You need to log in before you can comment on or make changes to this bug.