Bug 6318 - FTP to local machine: service not available.
FTP to local machine: service not available.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tcp_wrappers (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-24 20:43 EDT by kruggiero
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 14:38:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kruggiero 1999-10-24 20:43:35 EDT
I install the machine with the "KDE Workstation" options.
When I log in as a normal user, I try to FTP to the local
host.  It connects, then hangs for a moment (without
offereing a chance for me to log in).  Then, it gives a
message: service not available, and quits.

FTP works to other sites for me.  FTP appears to be a
started service by looking at the inetd.conf file (it's not
commented out).
Comment 1 ferrelli 2000-01-03 13:08:59 EST
I am experiencing the same problem with the same symptoms. I also have this
problem with Telnet. These utilities worked fine a few days ago and since then,
I have installed a different monitor and have worked on getting a PPP connection
up and running.
Comment 2 osman 2000-01-16 04:45:59 EST
What does the log file "/etc/messages" say?
Also try "telnet 127.0.0.1 21" and take a note about what it says...
Comment 3 Bernhard Rosenkraenzer 2000-02-17 14:38:59 EST
Workstation installs don't install an ftp server by default, so the behavior is
correct.
rpm -i /mnt/cdrom/RedHat/RPMS/wu-ftpd-2.6.0-1.i386.rpm should fix this.
If you want to permit anonymous access, install the anonftp RPM as well.

If you have installed wu-ftpd and anonftp, feel free to reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.