This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 63188 - Couple of UI fixes/enhancements
Couple of UI fixes/enhancements
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
7.3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-10 18:22 EDT by Owen Taylor
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 14:51:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Owen Taylor 2002-04-10 18:22:02 EDT
- When no users are selected the Actiosn on a particular user
  (menu and toolbar items) should be insensitized

- It would be nice to have the actions on a right click menu
  (right click on a row, get the list of actions on the 
  user. 

- The "Action" menu, probably should be "Actions", since
  we have "Preferences". ("Rule" seems to be that the menu
  name should either be a verb (File/Edit/Go...) or the
  a plural noun (Tasks, Bookmarks, Preferences)
  
- I'd add some separators to the Action menu - something like:
   
   New User
   New Group
   ---------
   Properties
   Delete
   ---------
   Exit
Comment 1 Brent Fox 2002-04-11 14:50:59 EDT
These all sound good.  However, it's late to be making these changes now.  I
also don't want the screenshots to get out of sync with the documentation, so
I'll make these changes as soon as we go gold.
Comment 2 Brent Fox 2002-08-19 17:56:47 EDT
- I've made the actions desensitized when no user is selected

- I haven't got the right click menu working yet.  Ran out of time for Milan.

- I've changed the "Action" menu to "File".  Although I don't think "File"
accurately describes the menu, others have suggested that "File" is most
commonly used in this situation and that an "Action" menu as the leftmost menu
is unusual.  So I changed it.

- I added some separators to the menu as described above.  

These are all in CVS now, except for the right click menu, which I will get to
someday.

Note You need to log in before you can comment on or make changes to this bug.