Bug 631912 - invest-applet left click claims 'server could not be contacted' but hover shows correct data
Summary: invest-applet left click claims 'server could not be contacted' but hover sho...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-08 16:27 UTC by Adam Williamson
Modified: 2011-01-04 20:54 UTC (History)
5 users (show)

Fixed In Version: gnome-applets-2.32.0-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-04 20:54:08 UTC


Attachments (Terms of Use)

Description Adam Williamson 2010-09-08 16:27:51 UTC
I think this started around the time of GNOME 2.32 stuff landing. I have invest-applet set up to give me a few stock quotes. It should give a summary of profit/loss as a tooltip if you hover over it, the icon itself should be red or green depending on if you have an overall loss or profit, and a left click should give detailed per-stock information as a little pop-up pane. Currently, the hover tooltip works and gives correct, updated data. However, the icon does not change color - it's not green or red, it uses the purple icon it would usually show if the server was down - and a left click pops up a dialog box which states 'No stock quotes are currently available. The server could not be contacted. The computer is either offline or the servers are down. Try again later.' with a Close button.

Comment 1 Adam Williamson 2010-09-08 16:28:57 UTC
In case it's not obvious - the computer is not offline and the servers are not down. The applet can clearly in fact retrieve data from the servers, or it would not be able to calculate the information that appears in the hover tooltip.

Comment 2 Matthias Clasen 2010-09-13 13:09:28 UTC
Running /usr/libexec/invest-applet -w -d yields:

2010-09-13 09:07:25.999345: Error while retrieving quotes data (url = http://finance.yahoo.com/d/quotes.csv?s=RHT&f=snc4l1d1t1c1ohgv&e=.csv): [Errno socket error] [Errno 110] Connection timed out

so, it seems to indeed not get any data.

Comment 3 Adam Williamson 2010-09-13 13:25:34 UTC
then where does the tooltip data come from? it's not old data, it changes constantly and appears current and accurate. does the tool have two separate data retrieval methods for the click and the tooltip? that sounds odd.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 David Robinson 2010-10-26 12:37:56 UTC
The upstream bug report is here:
https://bugzilla.gnome.org/show_bug.cgi?id=591723

and the fix for it is here:
http://git.gnome.org/browse/gnome-applets/commit/?id=d4bea685996cfb4fe38aab3a5763b2517e83bdbf

I can confirm that it fixes the problem (when applied to gnome-applets-2.32.0-1.fc14.x86_64).

Comment 5 Adam Williamson 2010-10-26 23:11:43 UTC
so they've finally got around to fixing the applet...just as I switched to GNOME Shell. le sigh =)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 6 Hervé Marcy 2011-01-02 19:04:04 UTC
Problem still not resolved for F14 and gnome-applets-2.32.0-2.fc14.x86_64 on my desktop

Comment 7 Leonardo Garcia 2011-01-03 00:53:30 UTC
I am having the same symptom described in this bug but, according to the debug info I collected, the bug I am seeing is the one described in the following upstream bug report:

https://bugzilla.gnome.org/show_bug.cgi?id=631418

The fix for this bug is here:

http://git.gnome.org/browse/gnome-applets/commit/?id=d4bea685996cfb4fe38aab3a5763b2517e83bdbf

It is available in the latest stable build of gnome-applets (2.32.1.2) which is newer than the version currently available in Fedora 14.

Comment 8 Fedora Update System 2011-01-03 12:53:50 UTC
gnome-applets-2.32.0-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnome-applets-2.32.0-3.fc14

Comment 9 Adam Williamson 2011-01-03 12:55:23 UTC
I've added the patch noted by Leonardo (thanks for the heads-up); please test the update and add karma. Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 10 Fedora Update System 2011-01-03 19:59:06 UTC
gnome-applets-2.32.0-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-applets'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gnome-applets-2.32.0-3.fc14

Comment 11 Leonardo Garcia 2011-01-04 00:42:15 UTC
Just tested the updated package and fix works for me. I was not the one to open this bug, but the fix solved the symptom I has having (which is the same as the one described in the bug).

Comment 12 Fedora Update System 2011-01-04 20:54:04 UTC
gnome-applets-2.32.0-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.