Bug 631987 - [abrt] brasero-2.31.91-1.fc14: g_variant_is_trusted: Process /usr/bin/brasero was killed by signal 11 (SIGSEGV)
[abrt] brasero-2.31.91-1.fc14: g_variant_is_trusted: Process /usr/bin/brasero...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: brasero (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
abrt_hash:e7ec927776313c2b6801f028c6f...
: CommonBugs, Triaged
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-09-08 15:52 EDT by Tobias Florek
Modified: 2010-10-05 13:55 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 13:55:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (35.39 KB, text/plain)
2010-09-08 15:52 EDT, Tobias Florek
no flags Details
Second Backtrace (hopefully better trace info) (17.87 KB, text/plain)
2010-09-22 00:30 EDT, John Watzke
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 627664 None None None Never

  None (edit)
Description Tobias Florek 2010-09-08 15:52:09 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: brasero
component: brasero
crash_function: g_variant_is_trusted
executable: /usr/bin/brasero
kernel: 2.6.35.4-12.fc14.x86_64
package: brasero-2.31.91-1.fc14
rating: 4
reason: Process /usr/bin/brasero was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1283975450
uid: 500

How to reproduce
-----
1. try to burn a data cd consisting of one big video file
2. watch it crash
Comment 1 Tobias Florek 2010-09-08 15:52:13 EDT
Created an attachment (id=446075)
File: backtrace
Comment 2 John Watzke 2010-09-09 23:56:30 EDT
Package: brasero-2.31.91-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Right click on an image to burn
2. Start the burn process
3. Crash


Comment
-----
If you look at the backtrace, you can clearly see this crash was due to the fact that I 
was trying to burn a Centos 5.5 DVD on Fedora 14. :-P
Comment 3 Adam Williamson 2010-09-13 12:48:40 EDT
Package: brasero-2.31.91-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Tried to burn an image
2.
3.


Comment
-----
Happens whether I go via nautilus or brasero. Running F14 + updates-testing, with an F15 kernel to solve a suspend bug.
Comment 4 David Hollis 2010-09-18 10:11:08 EDT
Package: brasero-2.31.91-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Attempt to use brasero to burn DVD iso
2. Click Burn, brasero immediately segfaults
3.
Comment 5 Place Holder 2010-09-19 09:53:15 EDT
Package: brasero-2.31.91-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I had just finished generating a live cd ISO file and wanted to burn it.
2. Loaded a blank CD into the drive, and was prompted to launch CD burning app.
3. Was the wrong app... so I quit it and launched Brasero.
4. Selected to burn an image/ISO file, selected the file, lowered the burn speed to min (10x).
5. Finished the dialog, and then it crashed.


Comment
-----
Brasero crashed while tying to burn a full CDR iso file.
Comment 6 John Reiser 2010-09-21 16:29:27 EDT
Package: brasero-2.31.91-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. right click on icon for .iso > Open with Brasero disk burner
2. confirm over-write of existing DVD+RW
3.
Comment 7 John Watzke 2010-09-22 00:30:44 EDT
Created attachment 448853 [details]
Second Backtrace (hopefully better trace info)
Comment 8 Jeff Raber 2010-09-22 01:59:32 EDT
This looks like https://bugzilla.gnome.org/show_bug.cgi?id=628899 which was closed as a dup of https://bugzilla.gnome.org/show_bug.cgi?id=627664, which is marked as RESOLVED.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Jeff Raber 2010-09-22 02:12:56 EDT
Nominating for F14Blocker under the criteria: "All applications listed under the Applications menu must withstand a basic functionality test and not crash after a few minutes of normal use."



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Adam Williamson 2010-09-22 04:37:29 EDT
Nice detective work, Xavier - desktop team, can you apply this fix ASAP? Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 satellitgo 2010-09-25 21:10:23 EDT
Package: brasero-2.31.91-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.try to burn a cd with Brasero
2.
3.
Comment 12 Adam Williamson 2010-09-27 21:56:56 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Fabien Archambault 2010-09-29 03:58:57 EDT
Package: brasero-2.31.91-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Copying a DVD to an iso file

Comment
-----
F14 Beta version on liveusb
Comment 14 Richard W.M. Jones 2010-09-29 10:50:59 EDT
Package: brasero-2.31.91-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Choose to burn a data disk.
2. Copy some files in and click "Burn"
3. Crash happens when you click "Burn several copies" button.
Comment 15 Richard W.M. Jones 2010-09-29 10:55:51 EDT
This should definitely be F14 blocker.  The application
is completely unusable for its primary purpose.  Also seems
to affect Nautilus, I assume they use the same code.
Comment 16 Adam Williamson 2010-09-29 11:03:29 EDT
Nautilus just uses Brasero.

Matthias says he's planning to bump GNOME to 2.32.0 soon (this week or next), which should include the upstream fix for this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Adam Williamson 2010-10-01 12:57:26 EDT
This was discussed at the 2010/10/01 blocker review meeting. We agreed that it constitutes a blocker under the criterion "All applications listed under the Applications menu must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items". Maintainer or desktop team, if you could push 2.32 ASAP that'd be great. Thanks!
Comment 18 Bill Nottingham 2010-10-04 16:49:48 EDT
Should be fixed with https://admin.fedoraproject.org/updates/gtk2-2.22.0-1.fc14,totem-2.32.0-1.fc14,brasero-2.32.0-1.fc14 - can you verify?
Comment 19 Tobias Florek 2010-10-04 17:50:33 EDT
will verify tomorrow.
Comment 20 Tobias Florek 2010-10-05 13:51:40 EDT
yes. using all updates from abobe i do not get this error.
Comment 21 Bill Nottingham 2010-10-05 13:55:32 EDT
OK, closing.

Note You need to log in before you can comment on or make changes to this bug.