Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 6320 - tcp_wrappers doesn't like ALL:ALL in hosts.deny with no newline
tcp_wrappers doesn't like ALL:ALL in hosts.deny with no newline
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: tcp_wrappers (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-25 00:29 EDT by bopol
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-25 00:29:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bopol 1999-10-25 00:29:28 EDT
in hosts.deny (i forget if it's the default, or if i added
it myself) i have

ALL:ALL[EOF]

so the line ends with EOF not end of line.  tcpd doesn't
like this and IGNORES it.  in the logs i get:

warning: /etc/hosts.deny, line 9: missing newline or line
too long

but then tcpd allows the connection through since it doesn't
think ALL:ALL is a good rule that should be applied.

tcpd should be fixed so that it accepts end of file as end
of a line.
Comment 1 Jeff Johnson 2000-07-27 16:23:08 EDT
tcp_wrappers already has a well defined parser, fix your file rather than the
program.

Note You need to log in before you can comment on or make changes to this bug.