Bug 632058 - No desktop icons or context menu on upgrade from F-14 Alpha to Rawhide
No desktop icons or context menu on upgrade from F-14 Alpha to Rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-09 00:16 EDT by Jon Masters
Modified: 2015-03-03 17:52 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-22 10:23:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Masters 2010-09-09 00:16:27 EDT
Description of problem:

Upgrading from F-14 to Rawhide results in a desktop session that allows one to explicitly invoke a view of the home directory via the "Places" menu, but does not include any desktop icons, nor is the traditional right-button context menu available.

Version-Release number of selected component (if applicable):

nautilus-2.90.1-2.fc15.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Install F-14 Alpha
2. Login to the Desktop (may not be required - but could be stale config?)
3. Upgrade to Rawhide
  
Actual results:

No desktop icons nor context menu are available. Running nautilus explicitly does not result in this starting either.

Expected results:

A series of desktop icons, a context menu, etc.

Additional info:
Comment 1 Jon Masters 2010-09-16 01:14:48 EDT
This is also present on a fresh rawhide install. No desktop icons or context menus.
Comment 2 Tomáš Bžatek 2010-09-16 02:54:42 EDT
Can you check that `gsettings get org.gnome.nautilus.preferences show-desktop` is 'true'? Does nautilus work otherwise? Are there any messages when starting nautilus from a terminal?
Comment 3 Jon Masters 2010-09-16 09:56:42 EDT
It is true. Seems to work otherwise. Today, I think this might be in contrast to previously, when starting from a terminal, I do now get the desktop icons appearing but the nautilus process on the terminal needs to remain running - previously if the desktop had died running "nautilus" on the terminal also resulted in some kind of background process starting to run the desktop icons.

The following output appears on the console:

[jcm@tonnant ~]$ nautilus
Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory
Initializing nautilus-gdu extension

(nautilus:1242): GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion `format != NULL' failed

(nautilus:1242): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

** (nautilus:1242): CRITICAL **: atk_object_initialize: assertion `ATK_IS_OBJECT (accessible)' failed

(nautilus:1242): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
Comment 4 Jon Masters 2010-09-16 09:58:02 EDT
Furthermore, logging out and logging in again after this does not seem to preserve the loading of nautilus in the subsequent session, even though the setting to load the desktop remains true.

Jon.
Comment 5 Qiang Li 2010-10-24 05:33:25 EDT
I installed fc14-beta and then updated to fc-rawhide with the same prolem, No icons on gnome desktop, `gsettings get org.gnome.nautilus.preferences show-desktop` returns 'true'. 

What's more, I can't find any item under '/app/nautilus/desktop' and '/app/nautilus/preferences' which there used to be some about gnome desktop settings. However, "grep 'show-desktop' /etc/gconf/schemas/*" returns nothings. It seems that some gconf schemas were lost. 

Nelson.
Comment 6 Raphos 2010-12-01 10:27:05 EST
I upgrade from F14 to Rawhide last week and the problem persists.

I created a launcher in my toolbar with the command "nautilus" and start it manually. Then the desktop and the icons are available.

When I restart or shutdown my computer, a message appears and tell me that "GNOME Settings Daemon" is still running.

Is this in relation with the problems ?
Comment 7 Raphos 2010-12-01 12:27:54 EST
(In reply to comment #6)
 
> Is this in relation with the problems ?

I reply to myself : no there is no relation with GNOME Settings Daemon.

GNOME Settings Daemon is working fine since today updates.
Comment 8 Qiang Li 2010-12-20 12:10:05 EST
I got the same problem.

'gsettings get org.gnome.nautilus.preferences show-desktop' returns "No such key 'show-desktop'".

Each time after I logging into gnome, I have to run 'nautilus --no-default-window' to get desktop icons back.
Comment 9 Matthias Clasen 2011-01-22 10:23:46 EST
nautilus is not going to be started by default in GNOME 3, so I don't think we want to consider this a bug anymore.
Comment 10 Bruno Wolff III 2011-01-22 13:19:15 EST
It isn't working with metacity either. (None of metacity, gnome-panel and nautilus appear to be started now.)
Comment 11 Raphos 2011-01-23 15:49:29 EST
@ Matthias

I don't understand the relation with GNOME 3.

Desktop icons don't appear when you switch from gnome-shell to "Standard" or "Compiz" in the "desktop-effects" panel.

Is this not a bug ?
Comment 12 Edouard Bourguignon 2011-04-06 05:21:23 EDT
Same bug here, using llvmpipe (so no gnome shell), desktop icons don't appear, and moreover can't copy files on the desktop.
Comment 13 Didier G 2011-04-15 05:53:57 EDT
(In reply to comment #9)
> nautilus is not going to be started by default in GNOME 3, so I don't think we
> want to consider this a bug anymore.

This choice in design is very annoying for people who will have to use gnome shell only in fallback mode.

It should be possible using gsettings to set an option to start or not nautilus by default.

Note You need to log in before you can comment on or make changes to this bug.