Bug 63206 - zsh displays "mc" cruft in runlevel 3 login shell
Summary: zsh displays "mc" cruft in runlevel 3 login shell
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mc (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-11 06:19 UTC by George Karabin
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 14:22:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description George Karabin 2002-04-11 06:19:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020314

Description of problem:
I have my login shell set to be /bin/zsh. When I login to a runlevel 3 text
prompt, a few lines of stuff (looks like the definition of a zsh shell function
called "mc") is printed to the screen uneccessarily. I don't see this for
subsequent terminal creation - just the login one. I could see this being a
problem with /bin/login or elsewhere, but I didn't see the problem when the
default shell was /bin/bash.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set default runlevel to be 3 in /etc/inittab
2. Set a user account's default shell to be /bin/zsh
3. Login to the user's account from the runlevel 3 login prompt
	

Actual Results:  The following text is printed to the screen (unindented -
indention here just for emphasis):

    Last login: Wed Apr 10 23:05:01 on tty1
    mc () {
            mkdir -p $HOME/.mc/tmp 2> /dev/null
            chmod 700 $HOME/.mc/tmp
            MC=$HOME/.mc/tmp/mc-$$
            /usr/bin/mc -P "$@" > "$MC"
            cd "`cat $MC`"
            /bin/rm -f "$MC"
            unset MC
    }


Expected Results:  I'd expect to see just the normal login message (unindented -
indention here just for emphasis):

    Last login: Wed Apr 10 23:05:01 on tty1

Additional info:

Comment 1 Trond Eivind Glomsrxd 2002-04-11 14:22:54 UTC
F

Comment 2 Trond Eivind Glomsrxd 2002-04-11 14:24:22 UTC
Fixed in mc-4.5.55-3


Note You need to log in before you can comment on or make changes to this bug.