Bug 63211 - redhat-config-users crashes when launched from Nautilus
redhat-config-users crashes when launched from Nautilus
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-users (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-11 04:42 EDT by Warren Togami
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 14:58:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-04-11 04:42:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020405

Description of problem:
When I attempt to run redhat-config-users from Nautilus, it displays for a split
second then immediately disappears.  The process appears to die.

Tested as root and non-root (via userhelper-gtk) with same result.

Version-Release number of selected component (if applicable):
redhat-config-users-1.0-12 from Rawhide

How reproducible:
Always

Steps to Reproduce:
1. Log into Gnome.
2. In "Start Here" select "System Settings" 
3. Select "User Manager"

Alternative to Reproduce:
1. Nautilus "/usr/bin"
2. Run redhat-config-users from there.

Actual Results:  
You see redhat-config-users run for a split second, but disappears immediately.

Expected Results:  
It shouldn't disappear.
Comment 1 Jay Turner 2002-04-11 07:32:45 EDT
Little more information here.  This is only happening when the application is
launched from Nautilus.  Calling the application directly works just fine. 
Pretty odd.
Comment 2 Nalin Dahyabhai 2002-04-11 11:11:10 EDT
Please check if upgrading to eel-1.0.2-10 (in today's Raw Hide) fixes this
problem (it should).
Comment 3 Warren Togami 2002-04-12 06:23:43 EDT
Tested and confirmed fixed.

Was the problem gtk2 related?
Comment 4 Brent Fox 2002-04-12 10:09:05 EDT
Well, yes and no.  Technically, it was a bug in eel, so no.  However, pygtk2
(libglade2 actually) was dumping some silly error messages to stdout.  However,
eel wasn't opening stdout correctly, so when libglade2 (used by
redhat-config-users) tried to write error messages to stdout which wasn't open,
the program would crash.  The new eel solves the problem by opening stdout
correctly.

Note You need to log in before you can comment on or make changes to this bug.