Bug 632126 - update dependency error: xulrunner-devel-1.9.1.12-1.fc12.x86_64 requires pkgconfig npsr-devel
update dependency error: xulrunner-devel-1.9.1.12-1.fc12.x86_64 requires pkgc...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
12
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-09 04:54 EDT by collura
Modified: 2010-09-21 01:12 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-21 01:12:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description collura 2010-09-09 04:54:43 EDT
Description of problem:
firefox 3.5.12-1.fc12(x86_64) and xulrunner-1.9.1.12-1.fc12.x86_64
updates fail on dependency check

Version-Release number of selected component (if applicable):
---> Package firefox.x86_64 0:3.5.12-1.fc12 set to be updated
---> Package xulrunner.x86_64 0:1.9.1.12-1.fc12 set to be updated
---> Package xulrunner-devel.x86_64 0:1.9.1.12-1.fc12 set to be updated

How reproducible:

always

Steps to Reproduce:
1. run updater
2. select firefox and xulrunner updates and select install
3. updater fails with error
  
Actual results:
firefox and xulrunner update is clogged

Expected results:
firefox and xulrunner update successfuly

Additional info:

# yum update
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package firefox.x86_64 0:3.5.12-1.fc12 set to be updated
---> Package xulrunner.x86_64 0:1.9.1.12-1.fc12 set to be updated
---> Package xulrunner-devel.x86_64 0:1.9.1.12-1.fc12 set to be updated
--> Processing Dependency: pkgconfig(nspr) >= 4.8.6 for package: xulrunner-devel-1.9.1.12-1.fc12.x86_64
--> Finished Dependency Resolution
Error: Package: xulrunner-devel-1.9.1.12-1.fc12.x86_64 (updates)
           Requires: pkgconfig(nspr) >= 4.8.6
           Installed: nspr-devel-4.8.4-2.fc12.x86_64 (@updates)
               pkgconfig(nspr) = 4.8.4
           Available: nspr-devel-4.8.2-1.fc12.i686 (fedora)
               pkgconfig(nspr) = 4.8.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Tomasz Kepczynski 2010-09-12 16:45:10 EDT
I also observe the same problem, however I was able to finally update firefox when I removed xulrunner-devel package. This may point directly to problem with that package.
Comment 2 John Sullivan 2010-09-13 08:27:32 EDT
Removing xulrunner-devel will side-step the problem, assuming you don't directly require xulrunner-devel, no other -devel package requires it, and you don't need to continue to be able to build any SRPM which BuildRequires it.

The underlying problem is that nspr-4.8.6-1 has been built, but not pushed to the repo yet ( http://koji.fedoraproject.org/koji/buildinfo?buildID=192106 ). Compare with bug 592356. This is the sort of dep problem that can and ought to be caught automatically and present packagers with a suitable warning ("You have just pushed an update which can't possibly work because the dependency AAAA-B.C-D has not yet been pushed"). I assume this is also the sort of thing the upcoming auto-QA will be able to do?
Comment 3 John Griffiths 2010-09-13 13:58:05 EDT
This also happens on i686.

--> Running transaction check
---> Package firefox.i686 0:3.5.12-1.fc12 set to be updated
---> Package xulrunner.i686 0:1.9.1.12-1.fc12 set to be updated
---> Package xulrunner-devel.i686 0:1.9.1.12-1.fc12 set to be updated
--> Processing Dependency: pkgconfig(nspr) >= 4.8.6 for package: xulrunner-devel-1.9.1.12-1.fc12.i686
--> Finished Dependency Resolution
Error: Package: xulrunner-devel-1.9.1.12-1.fc12.i686 (updates)
           Requires: pkgconfig(nspr) >= 4.8.6
           Installed: nspr-devel-4.8.4-2.fc12.i686 (@updates)
               pkgconfig(nspr) = 4.8.4
           Available: nspr-devel-4.8.2-1.fc12.i686 (fedora)
               pkgconfig(nspr) = 4.8.2
Comment 4 Donald Cohen 2010-09-17 04:28:10 EDT
same for me
Error: Package: xulrunner-devel-1.9.1.12-1.fc12.x86_64 (updates)
           Requires: pkgconfig(nspr) >= 4.8.6
           Installed: nspr-devel-4.8.4-2.fc12.x86_64 (@anaconda-InstallationRepo-200911081904.x86_64)
               pkgconfig(nspr) = 4.8.4
           Available: nspr-devel-4.8.2-1.fc12.i686 (fedora)
               pkgconfig(nspr) = 4.8.2
Error: Package: xulrunner-devel-unstable-1.9.1.12-1.fc12.x86_64 (updates)
           Requires: pkgconfig(nspr) >= 4.8.6
           Installed: nspr-devel-4.8.4-2.fc12.x86_64 (@anaconda-InstallationRepo-200911081904.x86_64)
               pkgconfig(nspr) = 4.8.4
           Available: nspr-devel-4.8.2-1.fc12.i686 (fedora)
               pkgconfig(nspr) = 4.8.2

For the moment I'm doing yum --skip-broken update
Comment 5 collura 2010-09-21 01:12:25 EDT
the nspr-4.8.6.1.fc12.x86_64 came through today

and after that  

firefox-3.5.12-1.fc12.x86_64
xulrunner-1.9.1.12-1.fc12.x86_64 

installed nicely.

thanks.

(i gather the skip broken would have worked for the firefox update but decided to keep them in sycn since release notes seemed to say they were paired so didnt want to potentially introduce other issues by running new firefox on old xulrunner.)

Note You need to log in before you can comment on or make changes to this bug.