Bug 632407 - proxy: error reading status line from remote server
proxy: error reading status line from remote server
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.5
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Joe Orton
Zbysek MRAZ
:
Depends On:
Blocks: 590060
  Show dependency treegraph
 
Reported: 2010-09-09 16:48 EDT by Bryan Mason
Modified: 2013-07-03 09:12 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 04:51:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of proxy-server (14.52 KB, text/plain)
2011-08-09 04:04 EDT, Gerrit Slomma
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache Bugzilla 37770 None None None Never

  None (edit)
Description Bryan Mason 2010-09-09 16:48:32 EDT
Description of problem:

    When attempting to access a backend IIS server through an Apache
    server running mod_proxy, the client receives a 502 error and
    lines smilar to the following appear in the Apache error log:

    [error] [client 10.1.2.3] proxy: error reading status line from
    remote server example.com

    [error] [client 10.1.2.3] proxy: Error reading from remote server
    returned by /example

Version-Release number of selected component (if applicable):

    httpd-2.2.3-31.el5_4.4

How reproducible:

    100%

Steps to Reproduce:

    1.  Configure mod_proxy to proxy an IIS server
    2.  Attempt to access the IIS server through mod_proxy

Actual results:

    502 error

Expected results:

    No error

Additional info:

    This is the same problem as:

       https://issues.apache.org/bugzilla/show_bug.cgi?id=37770

    Although Red Hat Bug 466723 would seem to indicate that this was
    resolved in RHEL 5.3, the patch included in the Apache Bug is not
    included in the latest version of the httpd package in RHEL 5.

    The RHEL 5.3 update to httpd rebased mod_proxy to upstream version
    2.2.9, but comments in the Apache Bug[1] would seem to indicate
    that this wasn't resolved until the release of Apache 2.2.10.

[1]https://issues.apache.org/bugzilla/show_bug.cgi?id=37770#c93
Comment 1 Joe Orton 2010-09-10 03:18:53 EDT
This version: httpd-2.2.3-31.el5_4.4 is significantly out of date.  There is at one fix to the proxy code since then.  Can you verity this issue is still present with the latest package? (httpd-2.2.3-43.el5_5.3)
Comment 2 Bryan Mason 2010-09-10 11:09:29 EDT
The problem was reported in httpd-2.2.3-31.el5_4.4, but I've verified that the patches in Apache bug 37770 are not present in the latest RHEL 5 package (httpd-2.2.3-43.el5_5.3).  The customer has verified that the problem was resolved in httpd-2.2.3-43.el5_5.3 with the patches the Apache bug, but I'll find out whether or not they tried httpd-2.2.3-43.el5_5.3 without the patches.
Comment 3 Jeremy Agee 2010-10-08 14:25:14 EDT
I double checked with the customer and they did try the stock httpd-2.2.3-43.el5_5.3 version.

This stock version would still get errors like:
(104)Connection reset by peer: proxy: error reading status line from remote server signweb-prodlike-sso.na.bestbuy.com, referer: http://signweb-prodlike.na.bestbuy.com/accessviaweb/web_dsignshop/MobileSignAudit.asp

proxy: Error reading from remote server returned by /accessviaweb/web_dsignshop/MobileSignAuditComplete.asp, referer: http://signweb-prodlike.na.bestbuy.com/accessviaweb/web_dsignshop/MobileSignAudit.asp

They can confirm that going from the stock httpd-2.2.3-43.el5_5.3 to the same version plus the two patches resolved the proxy errors.
Comment 5 Richard Huang 2010-12-09 04:22:02 EST
Hi,

Sorry I have to reopen this case. How did the customer apply the two patches? Did they build the mod_proxy*.so by themselves? Do we have any plan to include the patches on RHEL5? 

Thanks,
Richard
Comment 7 Kslinux 2010-12-23 03:03:34 EST
Hi 

I'm also getting same kind of error while using the mod_proxy..

[error] [client x.x.x.x] (104)Connection reset by peer: proxy: error reading status line from remote server 127.0.0.1, referer: http://abc.xyz.com/ABC/webcontents/common/jsp/ABCmain.jsp

[root@abc]rpm -qa |grep httpd
httpd-2.2.3-43.el5.centos.3

Regards,
Kslinux Team
Comment 14 Gerrit Slomma 2011-02-18 03:22:12 EST
Still there in httpd-2.2.3-45.el5

[Fri Feb 18 04:04:50 2011] [error] [client 18.3.7.144] (70014)End of file found: proxy: error reading status line from remote server aa.yy.zz
[Fri Feb 18 08:17:37 2011] [error] [client 42.5.1.36] (70014)End of file found: proxy: error reading status line from remote server xx.yy.zz, referer: http://xx.yy.zz/xx/schnellsuche.do?Nachname=xx
[Fri Feb 18 08:32:59 2011] [error] [client 48.3.3.36] (70014)End of file found: proxy: error reading status line from remote server aa.yy.zz, referer: http://xx.yy.zz/xx/verarbeiteBuchForm.do?nachname=&vorname=&dezernat=xx&fktgr=&telNr=&gebaeude=Br&raumNr=&stichwoerter=&action=Suche+starten
[Fri Feb 18 08:37:59 2011] [error] [client 32.4.8.51] (70014)End of file found: proxy: error reading status line from remote server aa.yy.zz, referer: http://xx.yy.zz/xx/schnellsuche.do?Nachname=xx
[Fri Feb 18 09:10:13 2011] [error] [client 32.4.6.17] (104)Connection reset by peer: proxy: error reading status line from remote server aa.yy.zz, referer: http://xx.yy.zz/xx/Login
Comment 21 Joe Orton 2011-02-26 09:35:59 EST
For anybody seeing this problem, a test repo is available
with experimental and *unsupported* packages which contain
a fix for this issue:

  http://people.redhat.com/jorton/Tikanga-httpd/
Comment 46 Yasuhiro Ozone 2011-06-27 07:15:13 EDT
Would this issue occur regardless of On Off of the "KeepAlive" switch ?
Comment 47 errata-xmlrpc 2011-07-21 04:51:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1067.html
Comment 48 errata-xmlrpc 2011-07-21 07:47:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1067.html
Comment 49 Gerrit Slomma 2011-08-09 04:03:25 EDT
The problem still persists! Please reopen as i can't do this!
Attached log.
If it is not reopend in one week i will open a new bug-ticket, could file a ticket via subscription too...
Comment 50 Gerrit Slomma 2011-08-09 04:04:56 EDT
Created attachment 517359 [details]
log of proxy-server
Comment 51 Gerrit Slomma 2011-08-09 04:05:59 EDT
# yum list httpd
Installed Packages
httpd.x86_64 2.2.3-53.el5 installed
Comment 52 Bryan Mason 2011-08-15 15:37:44 EDT
Hello Mr. Slomma - The best way to get your issue resolved would be to open a support case via the Red Hat Customer Portal (http://access.redhat.com/).

Note You need to log in before you can comment on or make changes to this bug.