Bug 63241 - /etc/init.d/ldap status always return 0
/etc/init.d/ldap status always return 0
Status: CLOSED DUPLICATE of bug 242666
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openldap (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jan Safranek
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2002-04-11 12:37 EDT by Marco Lusini
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-08 07:29:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Marco Lusini 2002-04-11 12:37:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Service script for OpenLDAP doesn't propagate status return codes,
and always return 0, even if openldap is not running.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.service ldap stop
2.service ldap status ; echo $?

Actual Results:  [root@iride root]# service ldap stop
[root@iride root]# service ldap status ; echo $?
slapd is stopped

Expected Results:  [root@iride root]# service ldap stop
[root@iride root]# service ldap status ; echo $?
slapd is stopped

Additional info:

It is important to propagate the return code in order to use service script 
with Cluster Manager
Comment 1 Joe Orton 2005-07-27 08:49:20 EDT
Still current; init script just needs a 


after the status call.
Comment 2 Matthew West 2006-04-07 21:16:43 EDT
Just want to confirm that as of 2006-04-07 this bug is still present in Fedora Core 5.
Comment 3 RHEL Product and Program Management 2007-05-30 04:45:03 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 4 Jan Safranek 2007-06-08 07:29:59 EDT

*** This bug has been marked as a duplicate of 242666 ***

Note You need to log in before you can comment on or make changes to this bug.