Bug 632459 - TurboGears2 incompatible with Pylons == 1.0
TurboGears2 incompatible with Pylons == 1.0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: TurboGears2 (Show other bugs)
14
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-09-09 22:05 EDT by Nils Philippsen
Modified: 2016-09-19 22:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: TurboGears2-2.1-0.3.rc1.dev1048.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-18 01:46:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2010-09-09 22:05:01 EDT
Description of problem:
When trying to start a tg2 app with paster in F-14, it fails because tg2 wants 'Pylons>=0.9.7,<1.0b1'.

Version-Release number of selected component (if applicable):
TurboGears2-2.1-0.2.b2.fc14.noarch
python-pylons-1.0-2.fc14.noarch
python-paste-1.7.4-7.fc14.noarch
python-paste-script-1.7.3-6.fc14.noarch

How reproducible:
Reproducible.

Steps to Reproduce:
A. Go into a TG2 app directory and start it with paster

-- or --

B. Just execute "paster" with tg2 installed
  
Actual results:

A.:

nils@gibraltar:~/web/Foo> paster serve --reload development.ini 
Traceback (most recent call last):
  File "/usr/bin/paster", line 9, in <module>
    load_entry_point('PasteScript==1.7.3', 'console_scripts', 'paster')()
  File "/usr/lib/python2.7/site-packages/paste/script/command.py", line 73, in run
    commands = get_commands()
  File "/usr/lib/python2.7/site-packages/paste/script/command.py", line 115, in get_commands
    plugins = pluginlib.resolve_plugins(plugins)
  File "/usr/lib/python2.7/site-packages/paste/script/pluginlib.py", line 81, in resolve_plugins
    pkg_resources.require(plugin)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 654, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 556, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (Pylons 1.0 (/usr/lib/python2.7/site-packages), Requirement.parse('Pylons>=0.9.7,<1.0b1'))
nils@gibraltar:~/web/Foo>

B.:

nils@gibraltar:~> paster
Usage: /usr/bin/paster COMMAND
Usage: paster [paster_options] COMMAND [command_options]

Options:
  --version         show program's version number and exit
  --plugin=PLUGINS  Add a plugin to the list of commands (plugins are Egg
                    specs; will also require() the Egg)
  -h, --help        Show this help message

Cannot load command tginfo: (Pylons 1.0 (/usr/lib/python2.7/site-packages), Requirement.parse('Pylons>=0.9.7,<1.0b1'))
Cannot load command quickstart: (Pylons 1.0 (/usr/lib/python2.7/site-packages), Requirement.parse('Pylons>=0.9.7,<1.0b1'))
Commands:
[...]

Expected results:

A. no error message, app started

B. no warnings about tginfo, quickstart, but descriptions of them

Additional info:

There seem to be some fixes regarding the Pylons version, but they refer to a version 0.10/0.10rc1 which seems ominous to me.

Also, the following commit seems to have typos which haven't been fixed since, it accesses "config['pylons.stritmpl_contextt_tmpl_context']" which doesn't exist in pylons (at least not mine) but strongly resembles a double-paste error:

commit 7a7a52bfab7cfbe31090387729483157b542ec5f
Author: percious <devnull@localhost>
Date:   Sun May 16 16:29:12 2010 -0400

    pylons 0.10 support started

Note that I used git-hg to get a read-only git copy of the repo (I miss too many git things in Mercurial), the corresponding Mercurial revision/changeset is 1035:16a62723c084.
Comment 1 Nils Philippsen 2010-09-09 22:08:19 EDT
I knew I would forget something this late:

- The fixes are post 2.1b2 in the upstream Hg repo
- Reproducer B. doesn't work inside a TG2 app directory (inside it behaves as A.)
Comment 2 Luke Macken 2010-09-14 16:10:01 EDT
TurboGears2.1 is currently incompatible with Pylons 1.0.  I just spoke with upstream, and apparently there are still a few more issues to iron out.

So, do we want pull Pylons 1.0 from F14?  or create a 0.9.7 compat package?
Comment 3 Nils Philippsen 2010-09-16 05:49:56 EDT
I'm not sure as I'm only using it through TurboGears, not directly. I'm fine with either.
Comment 4 Toshio Ernie Kuratomi 2010-09-16 14:02:25 EDT
There's a community who are using pylons directly so pulling pylons-1.0 probably isn't an option.

Compat package is an option.

Fixing the remaining issues in TG2 is another option.  lmacken and I are thinking this is the most desirable course.  I've packaged python-chameleon so we can start running the tg2 unittests and figure out what's broken.  Need someone to review:

https://bugzilla.redhat.com/show_bug.cgi?id=634388
Comment 5 Toshio Ernie Kuratomi 2010-09-19 01:54:38 EDT
python-chameleon review is done.  I'll build it for Fedora 14/rawhide next week.  So we should be able to start unittesting this soon.
Comment 6 Toshio Ernie Kuratomi 2010-09-19 16:03:12 EDT
https://admin.fedoraproject.org/updates/python-chameleon-1.2.12-4.fc14

While we wait for that to go to stable (won't be until after the f14 beta release) we should probably enable the test suite in rawhide and see what's broken.
Comment 7 Luke Macken 2010-09-28 13:47:05 EDT
Looks like upstream removed the Pylons<=0.9.7 requirement after last weekends sprints.

http://bitbucket.org/turbogears/tg-dev/changeset/d1228ef1e2c2
Comment 8 Fedora Update System 2010-09-30 14:36:30 EDT
TurboGears2-2.1-0.3.rc1.dev1048.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/TurboGears2-2.1-0.3.rc1.dev1048.fc14
Comment 9 Fedora Update System 2010-09-30 17:19:27 EDT
TurboGears2-2.1-0.3.rc1.dev1048.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update TurboGears2'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/TurboGears2-2.1-0.3.rc1.dev1048.fc14
Comment 10 Fedora Update System 2010-10-18 01:46:13 EDT
TurboGears2-2.1-0.3.rc1.dev1048.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.