Bug 632489 - Fail to read package metadata after specifying repo=
Fail to read package metadata after specifying repo=
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-09-10 01:03 EDT by He Rui
Modified: 2010-10-06 18:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-14.17.4-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 00:08:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the warning screen (69.58 KB, image/png)
2010-09-10 01:04 EDT, He Rui
no flags Details
/tmg/anaconda.log (11.76 KB, text/plain)
2010-09-10 01:05 EDT, He Rui
no flags Details
package installation err screen (71.40 KB, image/png)
2010-09-10 02:21 EDT, He Rui
no flags Details
anaconda.log when unable to open libgcc package (15.59 KB, text/plain)
2010-09-10 02:26 EDT, He Rui
no flags Details

  None (edit)
Description He Rui 2010-09-10 01:03:21 EDT
Description of problem:
Install F14 beta tc1 boot.iso with repo=http://, but anaconda is unable to retrieve specified package repo with the error screen(attached). Clicking retry has the same result, but if click edit and then click 'OK' without changing anything, the repo can be read successfully. 

Version-Release number of selected component (if applicable):
anaconda 14.17.1 
i386 and x86_64

How reproducible:
100%

Steps to Reproduce:
1. install F14-beta-tc1 boot.iso with repo=http://...
2. Proceed to package repository step
  
Actual results:
Fail to read package metadata. 

Additional info:
Click 'Edit' on the warning window and then click 'OK' without changing anything, the repo can be read successfully.
Comment 1 He Rui 2010-09-10 01:04:45 EDT
Created attachment 446428 [details]
the warning screen
Comment 2 He Rui 2010-09-10 01:05:37 EDT
Created attachment 446429 [details]
/tmg/anaconda.log
Comment 3 He Rui 2010-09-10 01:32:41 EDT
Mark it as Beta blocker according to beta criterion:

5. The installer must be able to use the HTTP, FTP and NFS remote package source options
Comment 4 He Rui 2010-09-10 02:21:25 EDT
Created attachment 446439 [details]
package installation err screen

The Additional info provided above seemed to be a workaround, but actually even if the repo is retrieved, during the package installation, it will fail for a package(seems to be a random one) will not be opened(See attached screen and anaconda.log).
Comment 5 He Rui 2010-09-10 02:26:49 EDT
Created attachment 446442 [details]
anaconda.log when unable to open libgcc package
Comment 6 Chris Lumens 2010-09-10 10:41:09 EDT
Radek - this is more of that "PYCURL ERROR 6" garbage that we've seen so much of recently.  Hopefully you can kill it once and for all.
Comment 7 Adam Williamson 2010-09-10 13:10:22 EDT
Discussed at today's blocker review meeting. We agreed this is a beta blocker under the criterion He Rui identified. Looks like anaconda team has an idea what the issue is.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Adam Williamson 2010-09-10 13:13:18 EDT
Please note the change deadline of 2010-09-14, we need the fix to be done by then. Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Radek Vykydal 2010-09-13 10:03:00 EDT
(In reply to comment #6)
> Radek - this is more of that "PYCURL ERROR 6" garbage that we've seen so much
> of recently.  Hopefully you can kill it once and for all.

Strange, it seems that we are not missing the urlgrabber.grabber.reset_curl_obj() to reset the resolver, but rather it is not working because backport of http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=59490a1c07f3fc094ab61f564aee3cacc5b57897 (the hunk adding isys.resetResolver) fixes the thing for me.
Also what is said in comment #4 is very suspicious.

Hui, does this updates image fix it for you?
http://rvykydal.fedorapeople.org/updates.resolvf14.img
http://rvykydal.fedorapeople.org/updates.resolvf14.img.iso

Note that you should not fetch it over network as to reproduce it should be brought up when setting up the repo. You can use the iso image above, "updates" boot parameter and select device with updates image in loader. 

Moreover, I noticed that in beta TC1, connections are not editable in nm-c-e, I wonder if it is related.
Comment 10 Radek Vykydal 2010-09-13 10:04:35 EDT
(In reply to comment #9)

> 
> Hui, does this updates image fix it for you?

Rui, apologies for garbling your name..
Comment 11 Radek Vykydal 2010-09-13 10:27:19 EDT

(In reply to comment #9)
> (In reply to comment #6)
> 
> Moreover, I noticed that in beta TC1, connections are not editable in nm-c-e, I
> wonder if it is related.

Hm, these syslog messages spit out when running nm-c-e are new:

18:26:20,593 ERR NetworkManager: polkit_authority_check_authorization: assertion `POLKIT_IS_AUTHORITY (authority)' failed
18:26:21,071 NOTICE NetworkManager:    ifcfg-rh: updating /etc/sysconfig/network-scripts/ifcfg-eth0
18:26:21,144 INFO polkitd: started daemon version 0.98 using authority implementation `local' version `0.98'
18:27:39,006 ERR NetworkManager: polkit_authority_check_authorization: assertion `POLKIT_IS_AUTHORITY (authority)' failed
Comment 12 Radek Vykydal 2010-09-13 11:04:08 EDT
(In reply to comment #11)

> 
> Hm, these syslog messages spit out when running nm-c-e are new:
> 
> 18:26:20,593 ERR NetworkManager: polkit_authority_check_authorization:
> assertion `POLKIT_IS_AUTHORITY (authority)' failed
> 18:26:21,071 NOTICE NetworkManager:    ifcfg-rh: updating
> /etc/sysconfig/network-scripts/ifcfg-eth0
> 18:26:21,144 INFO polkitd: started daemon version 0.98 using authority
> implementation `local' version `0.98'
> 18:27:39,006 ERR NetworkManager: polkit_authority_check_authorization:
> assertion `POLKIT_IS_AUTHORITY (authority)' failed

I opened a new bug #633315.
Comment 13 He Rui 2010-09-14 03:47:42 EDT
(In reply to comment #9)
> (In reply to comment #6)
> > Radek - this is more of that "PYCURL ERROR 6" garbage that we've seen so much
> > of recently.  Hopefully you can kill it once and for all.
> 
> Strange, it seems that we are not missing the
> urlgrabber.grabber.reset_curl_obj() to reset the resolver, but rather it is not
> working because backport of
> http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=59490a1c07f3fc094ab61f564aee3cacc5b57897
> (the hunk adding isys.resetResolver) fixes the thing for me.
> Also what is said in comment #4 is very suspicious.
> 
> Rui, does this updates image fix it for you?
> http://rvykydal.fedorapeople.org/updates.resolvf14.img
> http://rvykydal.fedorapeople.org/updates.resolvf14.img.iso
> 
> Note that you should not fetch it over network as to reproduce it should be
> brought up when setting up the repo. You can use the iso image above, "updates"
> boot parameter and select device with updates image in loader. 
> 

Yep, this issue is fixed with the updates iso you provided. Well done, thanks.
Comment 14 Radek Vykydal 2010-09-14 07:26:15 EDT
I sent the patch from updates file to a-d-l for review.
Comment 15 Radek Vykydal 2010-09-14 12:49:41 EDT
This should be fixed in anaconda-14.17.2-1.
Comment 16 Fedora Update System 2010-09-15 21:10:33 EDT
anaconda-14.17.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.17.2-1.fc14
Comment 17 Fedora Update System 2010-09-15 23:28:53 EDT
anaconda-14.17.2-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.17.2-1.fc14
Comment 18 Fedora Update System 2010-09-17 16:03:56 EDT
anaconda-14.17.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.17.3-1.fc14
Comment 19 Adam Williamson 2010-09-18 04:57:19 EDT
RC1 is now out and should include a fix for this:

http://serverbeach1.fedoraproject.org/pub/alt/stage/14-Beta.RC1/Fedora/

Please test and confirm this. Thanks!
Comment 20 James Laska 2010-09-20 15:25:41 EDT
Unable to reproduce using the i386 and x86_64 RC2 netinst.iso images.  Marking as VERIFIED
Comment 21 Fedora Update System 2010-09-20 19:32:05 EDT
anaconda-14.17.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.17.4-1.fc14
Comment 22 Fedora Update System 2010-09-20 23:51:04 EDT
anaconda-14.17.4-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.17.4-1.fc14
Comment 23 Fedora Update System 2010-09-22 00:07:30 EDT
anaconda-14.17.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Fedora Update System 2010-10-06 18:03:03 EDT
anaconda-14.18-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.18-1.fc14

Note You need to log in before you can comment on or make changes to this bug.