Bug 63251 - gcc crashed ( cpp0 segmentation fault )
gcc crashed ( cpp0 segmentation fault )
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-11 14:20 EDT by Suseelan Bhargavi Sarin
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 14:20:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suseelan Bhargavi Sarin 2002-04-11 14:20:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.51 [en] (X11; I; Linux 2.4.18 i686)

Description of problem:
I was trying to compile a 10 line test module and accidently entered gcc -Wall
-D -c test.c -o test.o instead of gcc -Wall -D MODULE -c test.c -o test.o.  The
program crashed requesting to make a bug report

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.take any c code, say junk.c
2. gcc -D -c junk.c -o junk.o

	

Actual Results:  bash-2.05# gcc -D -c test.c -o test.o
<command line>: macro names must be identifiers
gcc: Internal error: Segmentation fault (program cpp0)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
bash-2.05# 


Expected Results:  This was a silly error. It should have quited after
complaining about a NULL argument

Additional info:

bash-2.05# gcc --version
2.96
bash-2.05#
Comment 1 Jakub Jelinek 2002-04-11 17:45:02 EDT
gcc --version doesn't tell much, gcc -v is better.
Anyway, this has been fixed since gcc-2.96-100.

Note You need to log in before you can comment on or make changes to this bug.