This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 632510 - Installer exited abnormally when starting network in rescue mode
Installer exited abnormally when starting network in rescue mode
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-09-10 03:00 EDT by He Rui
Modified: 2010-10-06 18:03 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-14.17.4-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 00:08:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
traceback on Screen (69.26 KB, image/png)
2010-09-10 03:00 EDT, He Rui
no flags Details
/tmp/logs (12.09 KB, application/x-tar)
2010-09-10 03:01 EDT, He Rui
no flags Details

  None (edit)
Description He Rui 2010-09-10 03:00:47 EDT
Created attachment 446446 [details]
traceback on Screen

Description of problem:
Access to rescue mode using F14 beta tc1 x86_64 boot.iso, after selecting language and keyboard, start networking when prompted. anaconda exited abnormally as attached.     

Version-Release number of selected component (if applicable):
anaconda 14.17.1

How reproducible:


Steps to Reproduce:
1. Rescue mode using F14-beta-tc1
2. Setup networking
Comment 1 He Rui 2010-09-10 03:01:23 EDT
Created attachment 446447 [details]
/tmp/logs
Comment 2 He Rui 2010-09-10 03:22:20 EDT
Consider it's a beta blocker since it's relevant to:

The rescue mode of the installer must be able to detect and mount (read-write and read-only) LVM, encrypted, and RAID (BIOS, hardware, and software) installations
Comment 3 James Laska 2010-09-10 13:17:41 EDT
From the attachment in comment#0 ...

File "/usr/lib64/python2.7/site-packages/pyanaconda/rescue.py", line 97, in enableNetwork
  from netconfig_text import NetworkConfiguratorText

ImportError: No module named netconfig_text
Comment 4 Adam Williamson 2010-09-10 13:24:02 EDT
This was discussed at the blocker review meeting of 2010-09-10. We agreed that it should be a blocker, though we noted the existing criterion doesn't explicitly mention network functionality; we agreed to propose amending it, and accept the bug as a blocker on that basis.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2010-09-10 13:24:21 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Fedora Update System 2010-09-15 21:10:38 EDT
anaconda-14.17.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.17.2-1.fc14
Comment 8 Fedora Update System 2010-09-15 23:28:58 EDT
anaconda-14.17.2-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.17.2-1.fc14
Comment 9 Fedora Update System 2010-09-17 16:04:01 EDT
anaconda-14.17.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.17.3-1.fc14
Comment 10 Adam Williamson 2010-09-18 04:51:11 EDT
Tested with RC1, this works. Leaving the bug open as the build hasn't been pushed stable yet, but the fix is verified.
Comment 11 Fedora Update System 2010-09-20 14:41:52 EDT
anaconda-14.17.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.17.3-1.fc14
Comment 12 Fedora Update System 2010-09-20 19:32:19 EDT
anaconda-14.17.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.17.4-1.fc14
Comment 13 Fedora Update System 2010-09-22 00:07:44 EDT
anaconda-14.17.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-10-06 18:03:08 EDT
anaconda-14.18-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.18-1.fc14

Note You need to log in before you can comment on or make changes to this bug.